Search found 167 matches

by CrazyCat
Sat Jan 08, 2022 2:38 pm
Forum: Linking servers
Topic: Unreal 6.0.0 can't link (spkifp mismatch)
Replies: 3
Views: 303

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Excellent idea to add the warning.
by CrazyCat
Sat Jan 08, 2022 2:36 pm
Forum: General chat
Topic: using fingerprint for links, false good idea ?
Replies: 2
Views: 242

Re: using fingerprint for links, false good idea ?

Hi Syzop and thanks for the explanations. I understand that and I then will probably use a self-signed long-term certificate to link servers if my script doesn't feat how I hope. And for anope, the trouble is that I sometime have to stop the ircd where is located anope, so I make it join another ser...
by CrazyCat
Thu Jan 06, 2022 11:05 am
Forum: General chat
Topic: using fingerprint for links, false good idea ?
Replies: 2
Views: 242

using fingerprint for links, false good idea ?

Since I use spkifp, I frequently encounter troubles (failed authentication) with my links. WHY ? I use Let's encrypt certificates (wildcarded ones), so I met some problems: - only one of my servers (master) renew them, then I've to create a little script to copy them to other servers (done, working,...
by CrazyCat
Thu Jan 06, 2022 9:47 am
Forum: Installing and getting connected
Topic: Unreal 6.0.0 : prefixes for chanadmin and chanowner
Replies: 7
Views: 268

Re: Unreal 6.0.0 : prefixes for chanadmin and chanowner

I'll ask about that on anope forum, thanks Syzop !
by CrazyCat
Thu Jan 06, 2022 7:55 am
Forum: Installing and getting connected
Topic: Unreal 6.0.0 : prefixes for chanadmin and chanowner
Replies: 7
Views: 268

Re: Unreal 6.0.0 : prefixes for chanadmin and chanowner

Ok, the 6.0.1 works well after the correction of the issue #4454 but now I get lot of warn notice because of unknown mode setted by services (anope 2.0.10): 08:24:41 Zeolia -- avalon.zeolia.net: mode.REMOTE_UNKNOWN_CHANNEL_MODE [warn] Server services.zeolia.net sent us an unknown channel mode +q! 08...
by CrazyCat
Sat Jan 01, 2022 1:01 pm
Forum: UnrealIRCd modules (third party)
Topic: listrestrict not compatible with unreal6
Replies: 2
Views: 371

Re: listrestrict not compatible with unreal6

Sounds logical :)
BTW, I'll note for next upgrade to first disable plugins then upgrade :)
by CrazyCat
Tue Dec 28, 2021 5:38 pm
Forum: Installing and getting connected
Topic: Unreal 6.0.0 : prefixes for chanadmin and chanowner
Replies: 7
Views: 268

Re: Unreal 6.0.0 : prefixes for chanadmin and chanowner

No, this option seems to remove the levels, I want to not use the prefixes but keep the a and q levels. Support for compiling without PREFIX_AQ has been removed because people often confused it with disabling +a/+q which is something different. I want to compile with this, and having a and q show as...
by CrazyCat
Tue Dec 28, 2021 5:29 pm
Forum: Installing and getting connected
Topic: Unreal 6.0.0 : prefixes for chanadmin and chanowner
Replies: 7
Views: 268

Unreal 6.0.0 : prefixes for chanadmin and chanowner

Hi there,

I can't find the option to deactivate the prefixes for chanadmin and chanowner (& and ~).
After doing the upgrade, I had the bad surprise to notice they were activated. So I tried to recompile from the source, the option doesn't exists.

Did I forget something ?
by CrazyCat
Tue Dec 28, 2021 4:58 pm
Forum: Linking servers
Topic: Unreal 6.0.0 can't link (spkifp mismatch)
Replies: 3
Views: 303

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Ok, found. I don't edit my previous post but prefer to answer to had visibility to this solution: The ./unrealircd spkifp command use conf/tls/server.cert.pem and conf/tls/server.key.pem, it doesn't care of your tls settings in unrealircd.conf. So, if you use let's encrypt, you have to copy and rena...
by CrazyCat
Tue Dec 28, 2021 4:06 pm
Forum: Linking servers
Topic: Unreal 6.0.0 can't link (spkifp mismatch)
Replies: 3
Views: 303

Unreal 6.0.0 can't link (spkifp mismatch)

Hi there, My servers were working well together when using unreal5.2.2 I upgraded them and now they start but can't link: link.LINK_DENIED_AUTH_FAILED error: Link with server serv1.zeolia.net@X.X.X.X denied: Authentication failed: spkifp mismatch My link block are correct, I did ./unrealircd spkifp ...
by CrazyCat
Fri Dec 24, 2021 4:57 pm
Forum: Installing and getting connected
Topic: libcurl error
Replies: 4
Views: 346

Re: libcurl error

It was an update test, it looks like the system takes the path I gave when compiling the previous version.
BTW, I didn't remember having setted up this path, I'm pretty sure it cames from the "let us install curl for you" option.
by CrazyCat
Thu Dec 23, 2021 4:26 pm
Forum: Installing and getting connected
Topic: libcurl error
Replies: 4
Views: 346

Re: libcurl error

Ok, my bad, libcurl4-openssl-dev wasn't installed on the server.
If I remember well, previous versions of unreal had the option to install curl if needed, am I wrong ?
by CrazyCat
Thu Dec 23, 2021 3:12 pm
Forum: UnrealIRCd modules (third party)
Topic: listrestrict not compatible with unreal6
Replies: 2
Views: 371

listrestrict not compatible with unreal6

On one of my servers (not the same than the libcurl trouble), I tried to upgrade unreal5 to unreal6, I got compilation errors for listrestrict: make[5]: *** [Makefile:46: custommodule] Error 1 make[5]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src/modules/third' ***** Building 3rd party modul...
by CrazyCat
Thu Dec 23, 2021 3:07 pm
Forum: Installing and getting connected
Topic: libcurl error
Replies: 4
Views: 346

libcurl error

Hi there, My unrealircd is configured to use remote conf, but when I try to upgrade to unreal6, I get: checking curl_easy_init() in -L/home/zeolia/unrealircd/lib -lcurl... no configure: error: in `/home/zeolia/unrealircd-6.0.0': configure: error: You asked for libcURL (remote includes) support, but ...
by CrazyCat
Fri Dec 10, 2021 10:44 am
Forum: Installing and getting connected
Topic: SSL error with OpenSSl
Replies: 2
Views: 407

Re: SSL error with OpenSSl

I think you don't have server.cert.pem in conf/tls/, so you have to create the certificate.