UnrealIRCd 4 no longer supported

News about the UnrealIRCd project, including release announcements
Post Reply
Syzop
UnrealIRCd head coder
Posts: 1973
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

UnrealIRCd 4 no longer supported

Post by Syzop »

After five years it is time to say goodbye to the old UnrealIRCd 4 series. As of today, UnrealIRCd 4.x is no longer supported. This should be no surprise, given that the end-of-life announcement was in July 2019. And, of course, the repeated announcements pointing out the EOL date on the website, forums and twitter in 2020.

Still using UnrealIRCd 4?
If you are still using UnrealIRCd 4.x then you should upgrade ASAP to UnrealIRCd 5. The configuration file requires no mandatory changes, so in most cases upgrading from 4.x to 5.x is really easy. See the article Upgrading from 4.x for full information.
If you are using third party modules, then check on modules.unrealircd.org if they have been ported to 5.x. Otherwise, you can post the module source on the modules forum and ask if someone is kind enough to convert the module to 5.x.

Website changes
Now that UnrealIRCd 4.x is completely unsupported the following changes were made to the website:
  • The "UnrealIRCd 4 modules" forum section has been moved to the archives and is now read-only
  • The docs (wiki) have been updated to remove 4.x specific documentation and comments
  • Of course, the download page for 4.x has been removed.
Post Reply