Unreal 14.0.17 and anope 2.0.6 will not communicate on port 7000

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Post Reply
usalabs
Posts: 2
Joined: Sun May 13, 2018 6:33 pm

Unreal 14.0.17 and anope 2.0.6 will not communicate on port 7000

Post by usalabs » Sun May 13, 2018 6:48 pm

OK, so I've done everything and anything that can be done, I've edited this and that and the other, googled just about every question there is to ask, I've uninstalled, deleted removed, cleaned out and completely reinstalled both unreal 14, and anope 2, and they still will not talk to each other on localhost port 7000 (connection refused), now,,, as I've been through every setup and configuration there is, I now don't want someone telling me to try this, change that, remove this, post this file and that file, stand on my head while trying to yodel at the same time, ride a bike, and all that, as I've already done it,,, all I'm asking is for someone to take copies of 2 files (services.conf from anope, and unrealircd.conf) from a 100% working setup and after removing any passwords, to replace the host names with this, baring in mind unreal and anope will be running on the same server,:-

external hostname for unrealircd = irc-home.no-ip.org
internal hostname can be either localhost, 127.0.0.1, or 192.168.0.100

the passwords I can add myself.

I haven not as yet opened any ports in the hardware firewall and router, until I get the files to try out.

If someone can do that, and post the files here, I can copy/paste them and just add my passwords and in theory, being the files would have come from a working system, they should work for me (after someone changes the hostnames, etc etc).

Thanks in advance.

Stealth
Head of Support
Posts: 2080
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Re: Unreal 14.0.17 and anope 2.0.6 will not communicate on port 7000

Post by Stealth » Mon May 14, 2018 3:49 am

I know you probably don't want to hear it, but usually if you are getting "Connection Refused" it's a problem outside of UnrealIRCd and Anope. So, with that said...

I would suggest trying following, in order:
  1. Ensure UnrealIRCd has a listen block for port 7000.
  2. Check your netstat output to ensure UnrealIRCd is listening on *:7000 or 0.0.0.0:7000 (output will be dependent on your OS).
  3. Connect using a client or telnet or your preferred connection troubleshooting tool to localhost on port 7000 "telnet localhost 7000" - be sure to send the NICK command "NICK Test" as you might not get anything back from the server until it receives something from you.
  4. Connect from a different computer on the same LAN to port 7000 to confirm it works.
  5. Ensure Anope isn't trying to connect using SSL to a non-SSL port (or the other way around).
  6. Ensure Anope has the proper host to connect to as either "localhost" or "127.0.0.1"
Other than that, since I don't use Anope, hopefully someone can post a working link configuration. You can also post what you're currently using that doesn't work to see if someone can validate it's a good configuration. As I already mentioned, my bet is on an issue outside or Anope!

Stealth
Head of Support
Posts: 2080
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Re: Unreal 14.0.17 and anope 2.0.6 will not communicate on port 7000

Post by Stealth » Mon May 14, 2018 3:50 am

Also, I moved this to the Services forum since it is an issue with getting Anope linked to your server.

usalabs
Posts: 2
Joined: Sun May 13, 2018 6:33 pm

Re: Unreal 14.0.17 and anope 2.0.6 will not communicate on port 7000

Post by usalabs » Mon May 14, 2018 8:47 pm

Stealth wrote:
Mon May 14, 2018 3:49 am
I know you probably don't want to hear it, but usually if you are getting "Connection Refused" it's a problem outside of UnrealIRCd and Anope. So, with that said...

I would suggest trying following, in order:
  1. Ensure UnrealIRCd has a listen block for port 7000.
  2. Check your netstat output to ensure UnrealIRCd is listening on *:7000 or 0.0.0.0:7000 (output will be dependent on your OS).
  3. Connect using a client or telnet or your preferred connection troubleshooting tool to localhost on port 7000 "telnet localhost 7000" - be sure to send the NICK command "NICK Test" as you might not get anything back from the server until it receives something from you.
  4. Connect from a different computer on the same LAN to port 7000 to confirm it works.
  5. Ensure Anope isn't trying to connect using SSL to a non-SSL port (or the other way around).
  6. Ensure Anope has the proper host to connect to as either "localhost" or "127.0.0.1"
Other than that, since I don't use Anope, hopefully someone can post a working link configuration. You can also post what you're currently using that doesn't work to see if someone can validate it's a good configuration. As I already mentioned, my bet is on an issue outside or Anope!
My op, did suggest I'm running unrealircd and anope on the same machine, thereby they should both be able to talk to each other using localhost or just 127.0.0.1, and yes loclhost is used throughout the config files that relate to using port 7000, with exception to hosts that require a domain name such as services.localhost.net and port 7000 is not using SSL,

The uplink block in services.conf I have:-

host = "localhost"
ipv6 = no
port = 7000
ssl = no
password = "xxxxxxxxxxx"


and in the unrealircd.conf in the link block I have:-

Code: Select all

link services.localhost.net
{
        incoming {
                mask 127.0.0.1;
        };

        password "xxxxxxxxxx";

        class servers;
};
the link block wouldn't accept just localhost, I had to use a dotted host name.
I also added an outgoing block after the incoming, using:-

Code: Select all


outgoing {
                bind-ip *;
                port 7000;
               options [ serversonly; };
};
and that didn't work either. A netstat showed *:7000 listening

Post Reply