Unrealircd(Win32) & IRCServices(linux) problems... need

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Locked
pirulo2005
Posts: 9
Joined: Wed Feb 16, 2005 5:06 am

Unrealircd(Win32) & IRCServices(linux) problems... need

Post by pirulo2005 » Wed Feb 16, 2005 6:31 pm

I will show my config here and my problems. Help would be appreciated!
Thanks to all (and sorry because my post is VERY long)

I have 2 boxes:
1) Windows 2000 Server SP4 running UnrealIrcd 3.2 (192.168.1.10)
2) Linux (suse 7.1) running IRCServices. (192.168.1.11)

The IRC Server at box1 is working fine, but when I type /nickserv y get the answer “Services are currently down. Please try again later.â€

Ron2K

Post by Ron2K » Wed Feb 16, 2005 6:52 pm

OK. First off, it would be much appreciated if you posts stuff from config files within quote or code blocks. It's not an absolute requirement here, but it does make it easier for us mortals (ie me) to read.

Now, I read through those config extracts and noticed the following:

1: Your link block name in your unrealircd.conf and the server name in ircservices.conf are not consistent with each other. They both need to be the same. The IRCd is probably sending you "Link denied, no matching link block" or something like that. (Or maybe not, read the point below...)

2: I don't know where you got protocol/rfc1459 from, seing that example-ircservices.conf clearly says this:

Code: Select all

# Base IRC protocol module  [REQUIRED]
#     These modules provide the base functionality for communicating with
#     the remote IRC server, and MUST be loaded before any other module.
#     Select the module which matches the IRC server you are using:
#         protocol/bahamut      DALnet Bahamut server, versions 1.4.25+
#         protocol/dalnet       DALnet server, version 4.4.13 and earlier
#         protocol/dreamforge   DALnet Dreamforge server, versions 4.4.15+
#      [*]protocol/hybrid       Hybrid server, version 7.0
#         protocol/monkey       Chunky Monkey IRCD, version 1.0 and later
#      [*]protocol/ptlink       PTlink IRC server, version 6.0 and later
#         protocol/rfc1459      RFC1459-compliant servers
#         protocol/trircd       Trircd server, version 4.0 and later
#         protocol/ts8          RFC1459 with TS8 extensions
#         protocol/undernet-p9  Undernet server, version 2.9.x only
#         protocol/unreal       Unreal server, version 3.1.0 and later
#     Modules marked with [*] are still in an experimental stage and may
#     not be stable.
In other words, you've loaded the wrong protocol module.

Not sure what the HTTP errors have to do with all of this, but make the corrections that I've given you and see what happens next.

pirulo2005
Posts: 9
Joined: Wed Feb 16, 2005 5:06 am

Post by pirulo2005 » Wed Feb 16, 2005 7:31 pm

Sorry... i really dont know how to create those code boxes for posting code.
I will check what you have posted, and i will be back later. Hope it works!
Thanks!!!!!!

pirulo2005
Posts: 9
Joined: Wed Feb 16, 2005 5:06 am

Post by pirulo2005 » Wed Feb 16, 2005 8:25 pm

Ok Ron2K, I did what you told me...
Its not working, but at least things are different.
My ircservices.log is different, and i show it to you...
ircservices.log wrote: [Feb 16 17:08:39 2005] IRC Services 5.0.0 starting up
[Feb 16 17:08:39 2005] httpd/main: Listening on :8080
[Feb 16 17:08:40 2005] operserv/sline: warning: client IP addresses not available with this IRC server
[Feb 16 17:08:40 2005] user: New maximum user count: 1
[Feb 16 17:08:40 2005] user: New maximum user count: 2
[Feb 16 17:08:40 2005] unknown message from server (:scousens.no-ip.com ES)
Now, if i do a /whois nickserv, i get an answer:
/whois nickserv wrote: NickServ is scousens@fibertel.com.ar * Nickname Server
NickServ is a Network Service
nickserv End of /WHOIS list.
But if I do /nickserv name password, i get no answer, not even an error code.

What could it be?

pirulo2005
Posts: 9
Joined: Wed Feb 16, 2005 5:06 am

Post by pirulo2005 » Wed Feb 16, 2005 8:41 pm

Sorry, its working fine now!!!!!
Thanks alot!

Ron2K

Post by Ron2K » Thu Feb 17, 2005 7:36 pm

Glad you got it working.

However, I've just noticed something else...
pirulo2005 wrote:
ircservices.log wrote: [Feb 16 17:08:39 2005] IRC Services 5.0.0 starting up
That's a very old version - the latest is 5.0.45. I recommend that you upgrade (if you didn't do so already as part of your solution).

*** slaps self for not noticing this earlier ***

pirulo2005
Posts: 9
Joined: Wed Feb 16, 2005 5:06 am

Post by pirulo2005 » Fri Feb 18, 2005 3:25 am

Ok, i will check newer version.
Thanks!

Locked