Help with allow and class

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Locked
Fussi
Posts: 33
Joined: Fri Sep 24, 2004 9:46 pm
Location: At Home
Contact:

Help with allow and class

Post by Fussi » Fri Apr 01, 2005 9:32 pm

Hi there. I searched the forum for that already and found some solutions but they dont work for me.

What i want to do:
I want to add ~6 eggdrops to my server and they're running on the same machine.
I've set the following allow and class blocks: (The order in this post is the same as in the config file)

Code: Select all

class           clients
{
        pingfreq 90;
        maxclients 1000;
        sendq 100000;
        recvq 8000;
};

class           opers
{
        pingfreq 90;
        maxclients 20;
        sendq 500000;
        recvq 30000;
};

class           eggdrops
{
        pingfreq 90;
        maxclients 30;
        sendq 800000;
        recvq 30000;
};

Code: Select all

allow {
        ip             *@*;
        hostname       *@*;
        class           clients;
        maxperip 3;
};
allow {
        ip              *@<serverIP>;
        hostname        *@*;
        class           eggdrops;
        password        "<somepass>";
        maxperip 50;
};
Now i've added the PWD for the second Allow block to 2 of my eggdrops to test it. The first one connects w.o. any problems, but the second one gets kicked from the server:

Code: Select all

*** Notice -- Received KILL message for CommandGuard!CommandGua@96FED183.67526AF2.9DDFD550.IP from OperServ Path: services!OperServ (Session limit exceeded)
(I run a bouncer and another eggdrop on this server too, so we have exact these 3 connections for class "clients")

This is from my eggdrop config:

Code: Select all

set servers {
  <server>:<port>:<teh pass>
}
I'm playing around with that for 3 hours already, and i have no idea what to do now...
Can anyone help me with this?
(Maybe allow every connection from the local machine?)


-Fussi

Syzop
UnrealIRCd head coder
Posts: 1942
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Fri Apr 01, 2005 9:39 pm

The kill message you posted is from services, not from unreal. so i've moved this to the services section (most likely someone will reply soon)

Code: Select all

allow {
        ip              *@<serverIP>;
        hostname        *@*;
        class           eggdrops;
        password        "<somepass>";
        maxperip 50;
};
You must use hostname *@NOMATCH (or whater thing that doesn't match), because else everyone with a hostname that resolves will match that class. (Obviously this only applies to THIS class, in your main/catch-all class you should keep hostname *@*).
Last edited by Syzop on Fri Apr 01, 2005 9:40 pm, edited 1 time in total.

Ron2K

Post by Ron2K » Fri Apr 01, 2005 9:39 pm

This has nothing to do with UnrealIRCd - it's a services issue. You've obviously enabled session limiting (limiting how many clients can connect from the same location), and your 6 eggies on the same machine has set it off. Either add an exception for your eggies (you would have to check your services documentation to find out how), or disable session limiting entirely.

Fussi
Posts: 33
Joined: Fri Sep 24, 2004 9:46 pm
Location: At Home
Contact:

Post by Fussi » Fri Apr 01, 2005 9:49 pm

Allright, thanks!

That "this is from services" helped me :)
I deactivated the sessions module from operserv. Will re-run my tests tomorrow, too tired now :)

RandomNumber
Posts: 44
Joined: Mon Jan 24, 2005 6:10 pm

Post by RandomNumber » Mon Apr 04, 2005 2:58 pm

If its anope since it looks like it you can just do
/msg operserv exception add +0d *@EGGYIP's 50 Eggdrop's

Locked