Services Wont Work

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Services Wont Work

Post by Mike M » Thu Oct 06, 2005 3:24 pm

Hi i set my services up correctly and its connected to unreal alight but but says services is currently down i did what it said in the faq on unreal and still not working

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Thu Oct 06, 2005 3:31 pm

Did you /rehash?
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Thu Oct 06, 2005 3:32 pm

yes i did i ever restarted the server

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Thu Oct 06, 2005 3:37 pm

And /msg nickserv etc. works? (e.g. /msg nickserv help)
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Thu Oct 06, 2005 3:41 pm

nickserv No such nick/channel

but when i type /nickserv help it says Services are currently down. Please try again later.

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Thu Oct 06, 2005 3:44 pm

Well, your initial post was wrong. Your services are NOT connected to Unreal IRCd.
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Thu Oct 06, 2005 3:51 pm

that cant be right cause when i press connect in services it says this in ircd

-irc.foonet.com- *** Notice -- (link) Link irc.foonet.com -> services.localhost[@127.0.0.1.1127] established

btw my services are using port 6667

Solutech
Posts: 296
Joined: Thu Mar 18, 2004 11:38 pm

Post by Solutech » Thu Oct 06, 2005 5:55 pm

irc.foonet.com , hmmm maybe changing the default settings may help you out . If your server isnt closing the link you may not have ulined it or set its link block correctly. Id recommend you go read the user docs for unreal and check your unreal.conf top to bottom .

The server is only as good as the config file . Also try checking your services log file if you set services to log errors .
Yawn. So there's yet another "if the user clicks the button, they're infected" exploit. Why is this news? We already know users are idiots.

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Fri Oct 07, 2005 12:09 am

i dont understand why it isnt working i read everyewhere and still cant fix it

You are now an IRC Operator
-
-10.1.1.11- *** Notice -- (link) Link 10.1.1.11 -> services.localhost[@10.1.1.11.2485] established
-

when i type /chanserv help says

Services are currently down. Please try again later.



is my config code correct:
Moderator: DO NOT PASTE CONF FILES! http://forums.unrealircd.com/viewtopic.php?t=1146

Solutech
Posts: 296
Joined: Thu Mar 18, 2004 11:38 pm

Post by Solutech » Fri Oct 07, 2005 10:54 am

Have you ulined services ? Does services give you any form of error ? Im talking in the services client not from unreal .
Yawn. So there's yet another "if the user clicks the button, they're infected" exploit. Why is this news? We already know users are idiots.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Fri Oct 07, 2005 6:47 pm

Check your set::services-server. It should be the name of the services server.

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Sat Oct 08, 2005 9:42 am

still not working i did all u said

to put my services on i put htis in in the right places

link services.localhost
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 6667;
hub *;
password-connect "1234";
password-receive "1234";
class servers;
};

ulines {
services.localhost;
};

or it says i can do it this way but i dont know how to do it that way:

C:127.0.0.1:1234:services.localhost:6667:30
N:127.0.0.1:1234:services.localhost::30
H:*::services.localhost
U:services.localhost:*:*

w00t
Posts: 1136
Joined: Thu Mar 25, 2004 3:31 am
Location: Nowra, Australia

Post by w00t » Sat Oct 08, 2005 11:09 am

Stealth wrote:Check your set::services-server. It should be the name of the services server.
-ChatSpike IRC Network [http://www.chatspike.net]
-Denora Stats [http://denora.nomadirc.net]
-Omerta [http://www.barafranca.com]

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Sat Oct 08, 2005 11:13 am

is that the part you are talking about

// This points the command /nickserv to the user NickServ who is connected to the set::services.localhost

Mike M
Posts: 38
Joined: Wed Sep 28, 2005 10:44 am

Post by Mike M » Sat Oct 08, 2005 11:16 am

oh the other part i changed it and still not working

Locked