Remote server in services config (Please Help)

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

Remote server in services config (Please Help)

Post by CrashOverride » Sun Oct 22, 2006 5:30 pm

Hello

I am haveing trouble with getting the services to intergrate with unreal, the area i seem to be haveing trouble with is the sermote server connection in the config, this is how the code reads

# RemoteServer <hostname> <port> <password> [REQUIRED]
# Specifies the remote server hostname and port. The hostname may
# either be a standard Internet hostname or dotted-quad numeric
# address; the port number must be an integer between 1 and 65535
# inclusive. The password is a string which should be enclosed in
# double quotes if it contains any spaces (or just for clarity).
# Make sure to uncomment the directive (remove the leading "#") before
# running Services.
#
# The remote server and port may be overridden at runtime with the
# -remote command-line option. The password may not be set at runtime.

RemoteServer irc.clickerpower.net 6667 "password"


Now when i run ./ircservices i get this in the log

[Oct 22 00:28:07 2006] IRC Services 5.0.58 starting up
[Oct 22 00:28:37 2006] FATAL: Remote server returned: ERROR :Closing Link: [192.168.1.1] (Ping timeout)
[Oct 22 00:32:23 2006] IRC Services 5.0.58 starting up
[Oct 22 00:33:01 2006] FATAL: Remote server returned: ERROR :Closing Link: [192.168.1.1] (Ping timeout)

I am not real sure where i am going wrong, unless i need to add directives in the ircd.conf


Any ideas?

Ron2K

Re: Remote server in services config (Please Help)

Post by Ron2K » Mon Oct 23, 2006 5:42 am

CrashOverride wrote:unless i need to add directives in the ircd.conf
Firstly, it's unrealircd.conf, and secondly, yes you do (if you haven't already). Have a look at the link block documentation.

HelpChanneln00b
Posts: 28
Joined: Thu Jun 22, 2006 1:09 am
Location: UK

Reply: Remote server in services config (Please Help)

Post by HelpChanneln00b » Mon Oct 23, 2006 7:41 am

[192.168.1.1] (Ping timeout)
are you using a router? please CrashOverride as i think i know what the problem could be. and Ron2K, the unrealircd configuration file name can be changes in the config.h file and a few people do change it to ircd.conf, "as its alot more easyer".
Whats a help Channel without a n00b! :P

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

Code

Post by CrashOverride » Mon Oct 23, 2006 11:09 am

Yes i am behind a router, here is my link code in unrealircd.conf

link services.clickerpower.net
{
username *;
hostname services.clickerpower.net;
bind-ip *;
port 6667;
hub *;
password-connect "password";
password-receive "password";
class servers;
# options {
# /* Note: You should not use autoconnect when linking services */
# autoconnect;
# ssl;
# zip;
# };
};


Althou i am behind the router the server ip is DMZ

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

DNS

Post by CrashOverride » Mon Oct 23, 2006 11:14 pm

How about my dns settings would that impact the services??

HelpChanneln00b
Posts: 28
Joined: Thu Jun 22, 2006 1:09 am
Location: UK

Reply: Remote server in services config (Please Help)

Post by HelpChanneln00b » Tue Oct 24, 2006 2:45 am

Yeah, by the looks of things its probably your dns. The thing is that if your behind a router the ip address 192.168.1.1 is used to give static router ip address to people behind it, so the connecting to that address from your end will not work. you might need to change to something like 192.168.1.100. and get the dns to give it that address.
Whats a help Channel without a n00b! :P

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

DNS

Post by CrashOverride » Tue Oct 24, 2006 3:05 am

well the only address the dns knows is my Public IP

HelpChanneln00b
Posts: 28
Joined: Thu Jun 22, 2006 1:09 am
Location: UK

Reply: DNS

Post by HelpChanneln00b » Tue Oct 24, 2006 4:08 am

Your computer will ask the router to assign you and address with the dhc thing. But you can set it to use 192.168.1.1 to assign you an ip address of your choise. i dont use windows so i dont know how to do that on there. :roll: humm commonly depending on how many people are behind the router, the ip address alicated are 192.168.1.1xx like 192.168.1.100 and just keep adding 1 to it. If not then your router configuration is probably messed up. might want to re-check the manual?
Whats a help Channel without a n00b! :P

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

LAN

Post by CrashOverride » Tue Oct 24, 2006 11:15 am

The LAN is set up on a static ip system, the lan ip of the server is 192.168.1.40 there are 4 other pcs on that lan so in my code i am not sure if i need to be using the lan ip to link the services or my Public ip the one the net sees so i am a bit confused

SpaceDoG
Posts: 301
Joined: Mon Feb 27, 2006 5:44 am
Contact:

Post by SpaceDoG » Tue Oct 24, 2006 11:42 am

Are your server and services on the same box? if so set the hostname in the Unreal to hostname *; in your link block and update your services.conf file to be RemoteServer localhost 6667 "password"

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

same box

Post by CrashOverride » Tue Oct 24, 2006 11:51 am

yes both the ircd server and the services are on the same box,

SpaceDoG
Posts: 301
Joined: Mon Feb 27, 2006 5:44 am
Contact:

Post by SpaceDoG » Tue Oct 24, 2006 1:45 pm

Ok change the hostname to hostname *; in your linkblock in unrealircd.conf and in your services.conf put RemoteServer localhost serverport "password";

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

ok

Post by CrashOverride » Tue Oct 24, 2006 9:30 pm

ok now this is my new code ircds conf file

link services.clickerpower.net
{
username andy;
hostname 127.0.0.1;
port *;
bind-ip 127.0.0.1;
password-connect "PASSWORD";
password-receive "PASSWORD";
class servers;
};

ulines {
services.clickerpower.net;
};

And here is the services conf

RemoteServer localhost 6667 "PASSWORD"

and now i am getting this error

[Oct 24 17:19:06 2006] IRC Services 5.0.58 starting up
[Oct 24 17:19:35 2006] FATAL: Remote server returned: ERROR :Closing Link: [127.0.0.1] (Ping timeout)

Also here my my listen block

* NEW: listen {}

* OLD: P:Line

* This defines a port for the ircd to bind to, to

* allow users/servers to connect to the server.

* Syntax is as follows:

listen *:6667;
listen *:6668;
listen 127.0.0.1*:6667;

{

options

{

clientsonly;

};

};

wax
Posts: 72
Joined: Tue Oct 04, 2005 6:32 am
Location: ByNets@Belarus
Contact:

Post by wax » Tue Oct 24, 2006 9:39 pm

Code: Select all

link services.clickerpower.net 
{ 
username *; 
hostname 192.168.1.1; 
bind-ip *; 
port 6667; 
hub *; 
password-connect "password"; 
password-receive "password"; 
class servers; 
};

Code: Select all

RemoteServer 192.168.1.1 6667 "password"

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

ok

Post by CrashOverride » Wed Oct 25, 2006 3:18 am

how bout this

[Oct 24 23:14:24 2006] Databases loaded
[Oct 24 23:14:24 2006] Connected to Server 1 (localhost:6667)
[Oct 24 23:14:24 2006] FATAL: Remote server returned: ERROR :Closing Link: [127.0.0.1] (This port is for clients only)

Locked