Remote server in services config (Please Help)

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Re: ok

Post by Stealth » Wed Oct 25, 2006 4:20 am

CrashOverride wrote:how bout this

[Oct 24 23:14:24 2006] Databases loaded
[Oct 24 23:14:24 2006] Connected to Server 1 (localhost:6667)
[Oct 24 23:14:24 2006] FATAL: Remote server returned: ERROR :Closing Link: [127.0.0.1] (This port is for clients only)
Remove the clientsonly setting from your listen block in unrealircd.conf

SpaceDoG
Posts: 301
Joined: Mon Feb 27, 2006 5:44 am
Contact:

Re: ok

Post by SpaceDoG » Wed Oct 25, 2006 11:29 am

Code: Select all

link  services.clickerpower.net
{
 username *;
 hostname *;
 port 6679;
 bind-ip *;
 password-connect "PASSWORD";
 password-receive "PASSWORD";
 class servers;
};

ulines {
 services.clickerpower.net;
};

Code: Select all

RemoteServer   localhost 6667 "PASSWORD"

Code: Select all

 * NEW: listen {}
 * OLD: P:Line
 * This defines a port for the ircd to bind to, to
 * allow users/servers to connect to the server. 
 * Syntax is as follows:

listen *:6667;
listen *:6668;
listen 127.0.0.1:6679
{

	options

	{

		serversonly;

	};

};

CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm
Contact:

YAY

Post by CrashOverride » Wed Oct 25, 2006 9:58 pm

:o Well after painstakingly trying and trying and trying i switcehd my services to Anope after reading the posts about it
Well folks it paid off....

[Oct 25 17:43:54 2006] Anope 1.6.4 (874) (compiled for UnrealIRCd 3.1.1+) starting up
[Oct 25 17:43:55 2006] Attempting to load V3 HS Database
[Oct 25 17:43:55 2006] Databases loaded
[Oct 25 17:43:55 2006] Connected to Server 1 (localhost:6667)
[Oct 25 17:43:56 2006] user: New maximum user count: 1
[Oct 25 17:44:23 2006] user: New maximum user count: 2

YAY so now
that i have the link needed and the dreaded "services are down try later" message i need to make sure that the modulas are all loaded.

How do i check that and how do i get started using the services......i know the main thing i want to use is the /nickserv and the /chanserv to reserve nicks and channals
You all have been patient and helpfull

Locked