UnrealIRCd 4.0.1 + Anope -- No link block named

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Post Reply
Vegard
Posts: 6
Joined: Fri Feb 26, 2016 3:49 pm

UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Vegard » Fri Feb 26, 2016 4:03 pm

Hey all.

Running UIRCd 4.0.1 and whatever the most recent version of Anope is. And I am apparently rubbish at reading tutorials, because I am 100% unable to link Anope to UnrealIRCd! I have tried every variation I can think of in these configs now, with and without quotation marks, with and without static IP declarations, and everything else!

No link block named, bla bla bla.

For the love of everything good, can someone look over these and see if I've made any obvious mistakes? And if there are no mistakes, where do I look next to figure out this SUPER ANNOYING error?

unrealircd.conf:

Code: Select all

listen {
    ip 192.168.1.27;
    port 6900;
    options { serversonly; };
};

link anope.my-domain.com
{
    username *;
    hostname 192.168.1.27;
    bind-ip 192.168.1.27;
    port 6900;
    password-connect "anope";
    password-receive "anope";
    class servers;
};

ulines {
    anope.my-domain.com;
    listen 192.168.1.27;
};

anope/services.conf:

Code: Select all

define
{
    name = "services.host"
    value = "anope.my-domain.com"
}

uplink
{
    host = "192.168.1.27"
    ipv6 = no
    ssl = no
    port = 6900
    password = "anope"
}

serverinfo
{
    name = "anope.my-domain.com"
    description = "Anope Services"
}
-16:57:53- -irc.my-domain.com- *** vegard is rehashing server config file
-16:57:54- -irc.my-domain.com- *** Loading IRCd configuration..
-16:57:54- -irc.my-domain.com- *** Configuration loaded without any problems.
-16:58:15- -irc.my-domain.com- Link denied for anope.my-domain.com(unknown@test.my-domain.com) (No link block named 'anope.my-domain.com') [@192.168.1.27.39748]

Syzop
UnrealIRCd head coder
Posts: 1864
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Syzop » Mon Feb 29, 2016 9:41 am

The error means services is introducing itself with name X but there is no link block with name X.
According to your services.conf the hostname is anope.my-domain.com and in your link block in UnrealIRCd you have link anope.my-domain.com
In your pastes these names match 100%, but you probably changed these names in your pastes, right?
Anyway, this is where the error is.

Did you rehash your IRCd? Are there no configuration warnings or errors?
If you do '/STATS c' (as an ircop) do you see your services name listed? Be sure to check for spelling mistakes! :)
If it isn't listed then something is going wrong with reading your unrealircd configuration.

Vegard
Posts: 6
Joined: Fri Feb 26, 2016 3:49 pm

Re: UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Vegard » Tue Mar 01, 2016 9:54 am

Hello Syzop. Thanks for your time.

I redacted the domain because I usually do that, but it's LAN-only for now so might as well. Here's screenshots from the live configs:

http://imgur.com/YlOfCIc

http://imgur.com/uIHn3dk

And another IRC excerpt:
-10:39:51- * Connecting to 192.168.1.27 (6667)
-10:39:51- ºº¹¹ Welcome to the Internet Relay Network, Network
-10:39:51- Local host: vegard.vegardindustries.com (192.168.1.10)
-10:39:51- -irc.vegardindustries.com- *** Looking up your hostname...
-10:39:51- -irc.vegardindustries.com- *** Found your hostname (cached)
-10:39:51- ºººº (Clk-4A4FDCC0.vegardindustries.com) is now your hidden host
-10:39:51- ¹º¹¹ Users» (1), Invisible: (0), Servers: (1)
-10:39:51- º¹ºº Local clients» (1) on (0) server(s)
-10:39:51- º¹¹º 1 1 Current local users 1, max 1
-10:39:51- ºº¹º 1 1 Current global users 1, max 1
-10:39:51- º¹º¹ UserMode» set to (+iwx)
-10:40:06- ¹¹¹¹ (irc.vegardindustries.com) is now your hidden host
-10:40:06- ººº¹ UserMode» set to (+ost)
-10:40:06- ¹º¹¹ Server notice mask (+kcfvGqso)
-10:40:06- ¹¹ºº You are now an IRC Operator
-10:40:10- ¹¹¹º c End of /STATS report
-10:49:00- -irc.vegardindustries.com- *** vegard is rehashing server config file
-10:49:00- -irc.vegardindustries.com- *** Loading IRCd configuration..
-10:49:00- -irc.vegardindustries.com- *** Configuration loaded without any problems.
-10:49:41- -irc.vegardindustries.com- Link denied for anope.vegardindustries.com(unknown@test.vegardindustries.com) (No link block named 'anope.vegardindustries.com') [@192.168.1.27.45008]
-10:50:01- ºº¹¹ c End of /STATS report
Console printout for anope:
vegard@test:~$ services/bin/./services
Anope 2.0.3, build #2, compiled 10:13:20 Feb 25 2016
Using configuration file conf/services.conf
Attempting to connect to uplink #1 192.168.1.27 (192.168.1.27), port 6900
Successfully connected to uplink #1 192.168.1.27:6900
ERROR: Link denied (No link block found named 'anope.vegardindustries.com' or link::incoming::mask did not match your IP 192.168.1.27) [@192.168.1.27.45008]
ERROR: Closing Link: [test.vegardindustries.com] (Link denied (No link block found with your server name or link::incoming::mask did not match))
No errors other than what you can see in the excerpts above.

Vegard
Posts: 6
Joined: Fri Feb 26, 2016 3:49 pm

Re: UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Vegard » Tue Mar 01, 2016 10:11 am

For the sake of clarity, I can add explicitly that the whole server was just restarted, the config file revised, saved and then rehashed after the server booted. No errors or warnings except when trying to link anope.

Syzop
UnrealIRCd head coder
Posts: 1864
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Syzop » Wed Mar 02, 2016 11:34 am

The '/STATS c' command is used to list the link blocks in UnrealIRCd. In your case it gave an empty result. This means your link configuration is not being processed. This usually means one of two things: 1) editing the wrong file, or, 2) your block is within a comment
In your case it's the the latter.. you can see in your screenshot http://imgur.com/YlOfCIc that your link block is within a comment block that ends with */
I cannot see the start of the comment (which is /* ....) as it's above it.

So, first of all, move the link block to outside the /* ............ */ comment block, and then try again. You should then see configuration errors as your link block is using UnrealIRCd 3.2.x style instead of UnrealIRCd 4 but that's all solvable.

The correct UnrealIRCd 4 syntax in this case would be:

Code: Select all

link anope.my-domain.com
{
    incoming { mask 192.168.1.27; };
    password "anope";
    class servers;
};
That should fix your problem :)

Vegard
Posts: 6
Joined: Fri Feb 26, 2016 3:49 pm

Re: UnrealIRCd 4.0.1 + Anope -- No link block named

Post by Vegard » Sat Mar 26, 2016 3:20 am

Holy crap, it did work! :D

I need to do the config updates over FTP or something, editing in the terminal makes it so difficult to spot errors like those...

Thanks a lot!

Post Reply