/msg NickServ commands problem

The UnrealIRCd team does not officially provide support for any services packages that you may be using or want to use. This forum is provided so the community can help each other with services issues.

Moderator: Supporters

Post Reply
KaAzZ
Posts: 3
Joined: Mon May 16, 2016 6:55 pm

/msg NickServ commands problem

Post by KaAzZ » Mon May 16, 2016 7:10 pm

Hi everyone ,

Well I installed UnrealIRCd since few days as an hidden service , all is working fine , I can connect to it with my client through TOR , create channel etc... But I can't register my channels and use /msg Nickserv in general

/MSG ChanServ register #channel returns : "ChanServ :No such nick/channel" , same for NickServ
/nickserv help returns " NickServ :Services are currently down. Please try again later"

I saw on a few posts viewtopic.php?t=8282 that it could be the :

Code: Select all

set {
services-server "services.mynet.net";
};
OK fine , it will work if I put my onion hostname I am telling myself ! But it doesn't... So 127.0.0.1" but nothing works and I can't figure why...

Any help would be welcomed.

Thanks for reading and have a nice day

dboyz
Posts: 68
Joined: Tue Jun 14, 2011 6:36 am

Re: /msg NickServ commands problem

Post by dboyz » Wed May 18, 2016 8:50 am

As per https://www.unrealircd.org/docs/FAQ#.2F ... gain_later.

1. Firstly, please check if services has linked to your server. Since services is hidden, you need to OPER up, then do a MAP
2. "services.mynet.net" refers to the name of the server as defined in services config. This has nothing to do with hostname or any of the sort.

EXAMPLE, if your config is as such: https://github.com/anope/anope/blob/2.0 ... .conf#L205
You should replace "services.mynet.net" to "services.localhost.net"

KaAzZ
Posts: 3
Joined: Mon May 16, 2016 6:55 pm

Re: /msg NickServ commands problem

Post by KaAzZ » Thu May 19, 2016 8:33 pm

Hello , thanks for your answer , I understand know why it couldn't work :)

But now it is Anope's turn , I've get an "Unable to connect to uplink #1 (127.0.0.1:7000): Connection refused" whereas my config of both sides seems to be OK :

services.conf :

Code: Select all

define
{
  name = "services.localhost.net"
  value = "services.localhost.net"
}

uplink
{
  host = "127.0.0.1"

  /*
   * Enable if Services should connect using IPv6.
   */
  ipv6 = no

  /*
   * Enable if Services should connect using SSL.
   * You must have an SSL module loaded for this to work.
   */
  ssl = no

  /*
   * The port to connect to.
   * The IRCd *MUST* be configured to listen on this port, and to accept
   * server connections.
   *
   * Refer to your IRCd documentation for how this is to be done.
   */
  port = 7000

  /*
   * The password to send to the IRC server for authentication.
   * This must match the link block on your IRCd.
   *
   * Refer to your IRCd documentation for more information on link blocks.
   */

  password = "myPassword"
}

serverinfo
{
  name = "services.localhost.net"
[...]
}
unrealircd.conf :

Code: Select all

link services.localhost.net
{
  username ircd;
  hostname 127.0.0.1;
  bind-ip 127.0.0.1;
  port 7000;
  password-connect "myPassword";
  password-receive "myPassword";
  class servers;
};

ulines
{
services.localhost.net;
};


KaAzZ
Posts: 3
Joined: Mon May 16, 2016 6:55 pm

Re: /msg NickServ commands problem

Post by KaAzZ » Sat May 21, 2016 3:59 pm

I found the solution , I just had to edit the module block and configure it for unreal like this :

Code: Select all

module
{ 
name = "unreal"
}

Post Reply