Page 1 of 1

Cant link UnrealIRCd 4 with Anope 2

Posted: Mon Feb 20, 2017 11:06 pm
by afpromania28
Hello!

I tryed 2 days to connect Unreal4 with Anope, but i dont know why is not working and is so annoying doing this. :) Why so complicated?
I want to make a localhost server on Windows and i have:

services.conf:

Code: Select all

uplink 
{
	host = "127.0.0.1"
	ipv6 = no
	ssl = no
	port = 7000
	password = "parola"
}
and unrealircd.conf:

Code: Select all

ulines {
	services.chatprahova.ro;
};

link services.chatprahova.ro
{
	incoming {
		mask 127.0.0.1;
	};

	outgoing {
		bind-ip *; /* or explicitly an IP */
		hostname 127.0.0.1;
		port 7000;
		
	};

	password "parola";

	class servers;
};

listen {
	ip *;
	port 6667;
};

listen {
	ip *;
	port 6697;
	options { ssl; };
};

I am receiving this error and i dont know how to correct:

Code: Select all

[Feb 21 00:59:35 2017] Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 7000
[Feb 21 00:59:36 2017] Unable to connect to uplink #1 (127.0.0.1:7000)
[Feb 21 00:59:36 2017] Unable to connect to uplink #1 (127.0.0.1:7000)
[Feb 21 00:59:36 2017] Check that you are not connecting Anope to an SSL enabled port without configuring SSL in Anope (or vice versa)
[Feb 21 00:59:36 2017] Unable to connect to any uplink
Thanks!

Re: Cant link UnrealIRCd 4 with Anope 2

Posted: Tue Feb 21, 2017 1:56 am
by rcschaff
1) You don't need an outgoing on Unreal. Service connect to the server, not the other way around.

2) Try staring services with -nofork to see what errors you get, and post them here.

3) You need a listen block for port 7000 with {serversonly}

Re: Cant link UnrealIRCd 4 with Anope 2

Posted: Thu Feb 23, 2017 11:24 am
by afpromania28
I removes the outgoing params, i added a listen port 7000 but i have the same error log:

Code: Select all

[Feb 23 13:10:03 2017] Databases loaded
[Feb 23 13:10:03 2017] Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 7000
[Feb 23 13:10:04 2017] Unable to connect to uplink #1 (127.0.0.1:7000)
[Feb 23 13:10:04 2017] Unable to connect to uplink #1 (127.0.0.1:7000)
[Feb 23 13:10:04 2017] Check that you are not connecting Anope to an SSL enabled port without configuring SSL in Anope (or vice versa)
[Feb 23 13:10:04 2017] Unable to connect to any uplink
But it says aout SSL and i dont have a clue, on whats about :)

Re: Cant link UnrealIRCd 4 with Anope 2

Posted: Thu Feb 23, 2017 7:21 pm
by afpromania28
// later
I solved it. It was a different port for SSL, and i deleted the line "ssl = no". Also instead "servers;" changed to "serversonly;" Thanks!

Re: Cant link UnrealIRCd 4 with Anope 2

Posted: Sat Apr 07, 2018 10:42 am
by abi
afpromania28 wrote:
Thu Feb 23, 2017 7:21 pm
// later
I solved it. It was a different port for SSL, and i deleted the line "ssl = no". Also instead "servers;" changed to "serversonly;" Thanks!
can u explain what u modifit because my problem same to you