Page 1 of 1

Unreal 4.2 with Anope 2.0.6

Posted: Fri Nov 09, 2018 11:34 am
by GouroB
Can anyone please upload a full services.conf that connect's to Unreal 4.2 ... having multiple issues :( .. thanks in advance

Re: Unreal 4.2 with Anope 2.0.6

Posted: Fri Nov 09, 2018 5:39 pm
by SnowBlind
Both UnrealIRCd and Anope require configuration entries.

This is a basic example of a plain text password and connectivity configuration to connect to UnrealIRCd on Port 7000.
Note the 'services.yourdomainname.com' is a virtual host and does not need to be configured in DNS.

For Anope edit the default service.conf the key entries will be the define and uplink directive.

Code: Select all

define
{
	name = "services.host"
	value = "services.yourdomainname.com"
}

uplink
{
	host = "unrealircd ip address"
	ipv6 = no
	ssl = no
	port = 7000
	password = "insert random generated password here"
}
UnrealIRCd needs to be configured to accept Anope as a server on Port 7000 in the unrealircd.conf.

First you need to set a class directive for servers (I think this is just the default);

Code: Select all

class           servers
{
	pingfreq 90;
	maxclients 10;		/* Max servers we can have linked at a time */
	sendq 1000000;
	connfreq 100; /* How many seconds between each connection attempt */
};
Next you need to configure a link directive for the Anope server;

Code: Select all

link services.yourdomainname.com {
	incoming {
		mask *@*;
	};
	outgoing {
		bind-ip *;
		hostname ip address of anope server;
		port 7000;
	};
	password "same password as in uplink in services.conf";
	class servers;
};
Next you need to configure the U:Lines directive so that the Anope server has proper permissions.

Code: Select all

ulines	{
	services.yourdomainname.com;
	stats.yourdomainname.com;
};
Next you need to configure a listen directive for port 7000.

Code: Select all

listen {
	ip unrealircd ip address;
	port 7000;
};
This should get Anope connected. If not post the error messages.

Re: Unreal 4.2 with Anope 2.0.6

Posted: Sat Nov 10, 2018 4:40 am
by SnowBlind
I forgot one other setting in unrealircd.conf.

Code: Select all

set {
	services-server 	"services.yourdomainname.com";
	};
 

Re: Unreal 4.2 with Anope 2.0.6

Posted: Mon Nov 12, 2018 5:30 pm
by GouroB
thanks a lot man, but still not linking .. is it ok if i pm you my config files for a quick look ?

Re: Unreal 4.2 with Anope 2.0.6

Posted: Tue Nov 13, 2018 7:58 am
by CrazyCat
You can put your configs here, just hide your passwords.
No need of PM, unless you want that only one person helps you.

Re: Unreal 4.2 with Anope 2.0.6

Posted: Tue Nov 13, 2018 5:58 pm
by GouroB
CrazyCat wrote:
Tue Nov 13, 2018 7:58 am
You can put your configs here, just hide your passwords.
No need of PM, unless you want that only one person helps you.

thanks bunch CrazyCat, will post in a few mins :D

Re: Unreal 4.2 with Anope 2.0.6

Posted: Tue Nov 13, 2018 9:20 pm
by GouroB
Here are both file, please help me with them.

IRCD is running.

Unreal: https://pastebin.com/xxz1p7XU

Anope: https://pastebin.com/ZC7Tkxzu

Re: Unreal 4.2 with Anope 2.0.6

Posted: Wed Nov 14, 2018 11:32 am
by CrazyCat
Ok, I found some troubles.
unrealircd.conf wrote:link services.dxdhd.com
{
incoming {
mask *@*; /* you'd better use the same IP as in your anope.conf : mask 127.0.0.1;*/
};

outgoing {
bind-ip *; /* or explicitly an IP */
hostname irc.dxdhd.com; /* same as below: does irc.dxdhd.com point to 127.0.0.1 ? I don't think so
port 7000;
options { ssl; };
};

/* We use the SPKI fingerprint of the other server for authentication.
* Run './unrealircd spkifp' on the other side to get it.
* NOTE: requires UnrealIRCd 4.0.16 or later.
*/
password "AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPPQQRRSSTTUUV=" { spkifp; };

class servers;
};
To explain it more: have you a dns record irc.dxdhd.com with target 127.0.0.1 ? I hope that the answer is no, because it will forbid user to connect (redirected to their own computer :D).
So, be explicit with the IP, use 127.0.0.1 and not the DNS record.

Normaly, you may have messages in unreal saying that a server tries to connect but is not from the good host / ip.

If this fails, try to remove the ssl from the link and retry.