Blocking <something>.net/.com, except....

These are old archives. They are kept for historic purposes only.
cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Blocking <something>.net/.com, except....

Post by cculha » Sun Oct 09, 2005 8:29 pm

hi there are so many topic's. i want to write it in here. i want smt. in spamfilter so regex but i couldn't. if anyone know it please help. i want my server block the .net and .com like (a.net b.net c.com adad.com dasda.net) i can do that. but when i can do that the users can't send their email address like a@a.com . so nobody can use the command /msg nickserv register pass email@email.com

Now i want to regex command for : the users can't write anything with .net and .com EXCEPT @ if a user write kalaa.com it will be blocked but if he has written kala@kala.com it can pass..

Please help i am waiting your answers and please try it before answer.

Syzop
UnrealIRCd head coder
Posts: 1919
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Sun Oct 09, 2005 9:15 pm

Topic title updated to something more descriptive.

You cannot use excepts, except if you want really ugly regexes, it's in one of the topics somewhere (quite old).

For your problem though, you can suggest your users to use aliases instead, such as /NS REGISTER etc... Though, I know that is not a perfect solution.

cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Post by cculha » Sun Oct 09, 2005 9:17 pm

ohh my friend. it's a very bad problem i hope one day it can be resolve... orr can i add unreal a cod. when smbdy write /msg chanserv /msg nickserv /msg memoserv it changes automaticly by unreal /ns /ms /cs ? has you have any idea?

Jason
Posts: 570
Joined: Mon Jun 14, 2004 5:09 pm

Post by Jason » Sun Oct 09, 2005 11:49 pm

[^@][^ ]+\.(com|net)

Is your new regex
Why the hell can't my signature be empty?
"Your message contains too few characters."

cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Post by cculha » Mon Oct 10, 2005 7:40 am

no my friend. if i added this regex i can't send the mail adresses!!


[10:38] <Guest24898> a@a.net
[10:38] -super.geyik.net- Message to Cihan blocked: Spam/advertising

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Mon Oct 10, 2005 7:51 am

Deleted: nvm

cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Post by cculha » Mon Oct 10, 2005 8:31 am

?? it doesn'T happen. in that time i can't send the mails with @

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Mon Oct 10, 2005 9:41 am

It just can't be done (easily).

But an alternative could be the following:
-> Use the Badwords system to block *.net and *.com
-> Force all users and channels to be +G using set::modes-on-connect, set::modes-on-join, set::restrict-usermodes and set::restrict-channelmodes (or even better: compile Unreal so that channels are automatically filtered - there's an option)
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Post by cculha » Mon Oct 10, 2005 2:22 pm

(or even better: compile Unreal so that channels are automatically filtered - there's an option)


i couldn't understand what do you mean?

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Mon Oct 10, 2005 2:24 pm

There's a compilation option so that badwords in channels are always filtered even if they are not +G.
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

aquanight
Official supporter
Posts: 862
Joined: Tue Mar 09, 2004 10:47 pm
Location: Boise, ID

Post by aquanight » Mon Oct 10, 2005 4:41 pm

Dukat wrote:There's a compilation option so that badwords in channels are always filtered even if they are not +G.
If you're referring to STRIP_BADWORDS... actually... that's the one that enables +G to work in the first place ;) .

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Mon Oct 10, 2005 4:50 pm

No, I'm talking about STRIPBADWORDS_CHAN_ALWAYS :D
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

aquanight
Official supporter
Posts: 862
Joined: Tue Mar 09, 2004 10:47 pm
Location: Boise, ID

Post by aquanight » Mon Oct 10, 2005 6:39 pm

Heh... I don't think I've ever seen that one. Interesting.

Jason
Posts: 570
Joined: Mon Jun 14, 2004 5:09 pm

Post by Jason » Mon Oct 10, 2005 9:04 pm

What the HELL? See the [^@] at the beginning? Emails are exempt from that regexp!

Hmm.. Try changing it to..

[^@][^ @]+\.(com|net)
Why the hell can't my signature be empty?
"Your message contains too few characters."

cculha
Posts: 79
Joined: Tue Sep 13, 2005 1:16 am

Post by cculha » Mon Oct 10, 2005 9:10 pm

ok if you know something. write the full command. i don't want sdad.net but i want asda@sdad.net ok?

Post Reply