Loading Unreal 3.2 on windows Xp

These are old archives. They are kept for historic purposes only.
Post Reply
Squall89
Posts: 10
Joined: Sat Jan 15, 2005 12:54 pm

Loading Unreal 3.2 on windows Xp

Post by Squall89 »

hello,

i'm having a problem with starting Unreal 3.2.
When I read the log file i see the following
lines:
* Loading IRCd configuration ..
[error] unrealircd.conf:702: set::kline-address must be an e-mail or an URL
[error] set::kline-address missing
[error] 2 errors encountered
[error] IRCd configuration failed to pass testing

If I got to line 702 i see this line hosts { .

I don't know what i have to do now,
how can I solve this problem ?

thx for your help !
Solutech
Posts: 296
Joined: Thu Mar 18, 2004 11:38 pm

Post by Solutech »

You havent configured the .conf properly . Go back and enter the information it asks for . Read the docs at http://www.vulnscan.org/UnrealIrcd/unreal32docs.html to get a clearer idea on how to configure .conf .
Squall89
Posts: 10
Joined: Sat Jan 15, 2005 12:54 pm

Post by Squall89 »

i've read the docs but i don't know what is mean with this part,
because i haven't find this lines at this faq..
Maybe the problem is that i've read the Faq on german...
McTerry
Posts: 64
Joined: Tue Oct 19, 2004 12:42 am
Location: *.se
Contact:

Post by McTerry »

Look for this in your configuration file.

set {
kline-address my@emailaddress.com;
auto-join #welcome;
options {
hide-ulines;
};
hosts {
local LocalOp.MyNet.com;
global globalop.mynet.com;
};
};

Notice that "kline-adress" shows an e-mail. There you should write your own mail adress where all your klined messages will be sent. (I think)
Just change it and it should work hopefully.
BOOM!
Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat »

The kline-address is displayed to banned users, so that they can ask for help etc. :D
Squall89
Posts: 10
Joined: Sat Jan 15, 2005 12:54 pm

Post by Squall89 »

hi, thx for your help, but now i have another problem,
I get this line
* Loading IRCd configuration ..
* unrealircd.conf:319: link hub.mynet.com with SSL option enabled on a non-SSL compile
[error] 1 errors encountered
[error] IRCd configuration failed to pass testing

But If I just delet the section with ssl, in this lines ther i get another
error:

[error] ERROR: No cloaking module loaded. (hint: you probably want to load modules\cloak.dll)
[error] If you are upgrading from 3.2 (or any older version), be sure to read the release notes or http://www.vulnscan.org/tmp/newcloak.txt regarding the cloaking change!
[error] IRCd configuration failed to pass testing

How can I solve this ? Btw. is that normal that when your solve an error that then you get other errors ?
Ron2K

Post by Ron2K »

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat »

Or the FAQ:
http://www.vulnscan.org/UnrealIrcd/faq/#71
Squall89 wrote:is that normal that when your solve an error that then you get other errors ?
Yes, if you don't read the manual. :?
Squall89
Posts: 10
Joined: Sat Jan 15, 2005 12:54 pm

Post by Squall89 »

yeaah i have managed it, but is that normal,
that there is no tray icon or something else,
which shows that the programm is working ?
and how do i get the services like chanserv,
nickserv ect ? Because i have only found them
for linux..
Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat »

If you installed Unreal as a service (which is explicitly marked as an advanced option!), there is no icon.


For Services, have a look at this thread:
http://forums.unrealircd.com/viewtopic.php?t=312
Post Reply