Spamfilter Issue - Removal of

These are old archives. They are kept for historic purposes only.
Post Reply
Nettworkz
Posts: 10
Joined: Wed Dec 01, 2004 6:29 pm

Spamfilter Issue - Removal of

Post by Nettworkz » Fri Aug 26, 2005 11:02 pm

I have an oper that set multiple spamfilters that seemingly are not removeable. I've tried multiple times but when I issue the /spamfilter del command, it doesn't remove the filter, or even acknowledge that I tried to.

Example:

[Moderator: did you really have to paste all that?]


There are at least 8 of these that I've yet to be able to get to remove. Anyone
have any suggestions?

Thanks

aquanight
Official supporter
Posts: 862
Joined: Tue Mar 09, 2004 10:47 pm
Location: Boise, ID

Post by aquanight » Fri Aug 26, 2005 11:10 pm

First, check if the spamfilter is listed in your unrealircd.conf file. If it is you have to remove it there and /rehash. Otherwise, most likely your regex is so long it's getting cut off. You'll have to remove it the hard way: /restart ALL servers on your network.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Fri Aug 26, 2005 11:14 pm

The regex can't be "too long", or they could not have been set.

Nettworkz
Posts: 10
Joined: Wed Dec 01, 2004 6:29 pm

Re: Spamfilter Issue - Removal of

Post by Nettworkz » Fri Aug 26, 2005 11:18 pm

Nettworkz wrote: [Moderator: did you really have to paste all that?]
Yes. Do you know of a better way to offer an example of exactly what the problem is? If you ever expect to get correct answers to questions, you surely have to ask the right question.

Since my example was removed, I'll post a shorter one..

*** F c block 0 2974523 86400 Spam/advertising @@@@@@@@@ - @'s repeated ad nauseum.

Nettworkz
Posts: 10
Joined: Wed Dec 01, 2004 6:29 pm

Post by Nettworkz » Fri Aug 26, 2005 11:22 pm

aquanight wrote:First, check if the spamfilter is listed in your unrealircd.conf file.
Hi Aquanight, thanks for the suggestion. No it's not listed in the *.conf files. It was added "live" online by one of the opers. She swears she only set it once, but if a server happens to split, and come back, it's been setting it again on a reconnect.

Syzop
UnrealIRCd head coder
Posts: 1915
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Fri Aug 26, 2005 11:22 pm

Perhaps try doing '/nick a' (yes 1 character), and then doing '/spamfilter' and copypaste it again to /spamfilte del.... :P.

That could give space for a few characters extra :p.

Also, I guess, if that didn't work, try it from the server with the shortest name.

A wonderful solution...


I guess bug #2083 ('SpamFilter Problem') needs to be bumped ;).

Nettworkz
Posts: 10
Joined: Wed Dec 01, 2004 6:29 pm

Post by Nettworkz » Fri Aug 26, 2005 11:24 pm

Syzop wrote:I guess bug #2083 ('SpamFilter Problem') needs to be bumped ;).
I'm sorry if I missed this on the forums, I did do a search for similar problems but didn't run across a post about it. Apologies.

Syzop
UnrealIRCd head coder
Posts: 1915
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Fri Aug 26, 2005 11:30 pm

It's an entry in the bugtracker :). Still, it was on the last page or so though ;p

White_Magic
Posts: 267
Joined: Tue Jan 18, 2005 3:24 pm
Location: Scotland - United Kingdom

Post by White_Magic » Sun Aug 28, 2005 9:39 am

-> Temptation.*.net SPAMFILTER add c block - - @@@@@@@@@

[10:07] *** Spamfilter added: '@@@@@@@@@' [target: c] [action: block] [reason: SJ pam/Advertising] on Sun Aug 28 09:07:24 2005 GMT (from newnicknameonly!Sjdje3@Admin.*.net)
-
-> Temptation.*.net SPAMFILTER del c block - - @@@@@@@@@

<- :Temptation.*.net NOTICE newnicknameonly :newnicknameonly!Sjdje3@Admin.Chatuniverse.net removed Sp

[10:07] newnicknameonly!Sjdje3@Admin.*.net removed Spamfilter '@@@@@@@@@' (set at Sun Aug 28 09:07:24 2005)


im sorry i fail to be able to find a problem with this, it seems to me your not using the del or - command properly or ur on a older server version, (running on 3.2.3)
i spend 4 hrs a day gaming and 14hrs on irc, for 5days a week, im not an addict :D

w00t
Posts: 1136
Joined: Thu Mar 25, 2004 3:31 am
Location: Nowra, Australia

Post by w00t » Sun Aug 28, 2005 12:57 pm

Given it's an entry in the bugtracker, and syzop has provided suggestions- I'd say that there is actually a problem there ;)
-ChatSpike IRC Network [http://www.chatspike.net]
-Denora Stats [http://denora.nomadirc.net]
-Omerta [http://www.barafranca.com]

Nettworkz
Posts: 10
Joined: Wed Dec 01, 2004 6:29 pm

Post by Nettworkz » Sun Aug 28, 2005 1:34 pm

White_Magic wrote: im sorry i fail to be able to find a problem with this, it seems to me your not using the del or - command properly or ur on a older server version, (running on 3.2.3)
See this is why my original example should not have been removed :roll:, it wasn't a spamfilter on "@@@@@@@@@@@@", the @ signs were repeated for five full lines, as displayed on mirc.

I do thank Syszop for his suggestion though, I was able to remove the spamfilter.

Post Reply