Startup probs

These are old archives. They are kept for historic purposes only.
Post Reply
damousys
Posts: 5
Joined: Tue Sep 06, 2005 1:17 pm
Contact:

Startup probs

Post by damousys » Tue Sep 06, 2005 1:26 pm

I am receiving an error while i start unreal ircd version 3.2.3
It's not at the nice start up screen but at the ircd.log

this is my error

[Tue Sep 06 09:24:43 2005] - Error binding stream socket to IP 0.0.0.0 port 6667 - server1.damousys.nl[]:Permission denied

i think that i have edited the example.conf at the right way, but i didn't set any IP adres certainly not 0.0.0.0

i have disabled this because i don't use any services yet.
for the rest i didn't anything only some servernames.

Code: Select all

/*
link            hub.mynet.com
{
	username	*;
	hostname 	1.2.3.4;
	bind-ip 	*;
	port 		7029;
	hub             *;
	password-connect "LiNk";
	password-receive "LiNk";
	class           servers;
		options {
			/* Note: You should not use autoconnect when linking services */
			autoconnect;
			zip;
		};
};
*/

nate
Posts: 148
Joined: Fri Jul 29, 2005 10:12 am
Location: Johnstown, Pa
Contact:

Post by nate » Tue Sep 06, 2005 2:54 pm

you need to set an IP address, especially if its for services.

If you are setting up for Services, you want to set the host name to something like 127.0.0.1 if you are placing services perhaps on the same system, or the network IP (not external IP unless your services is located outside of your LAN) of the system hosting the services module.

Such as:

Code: Select all

link "Services.yourdomain.net" { 
	username *; 
	hostname 127.0.0.1; 
	bind-ip *;
	port 6655;
	hub *;
	password-connect "PassWord"; 
	password-receive "PassWord";
	class servers;
};
Something such as that.

damousys
Posts: 5
Joined: Tue Sep 06, 2005 1:17 pm
Contact:

Post by damousys » Tue Sep 06, 2005 2:59 pm

So i do need to put that link block in my conf ?
i don't run any service's yet
that's my next step
and by the way i am a total noob with Unreal IRCD

nate
Posts: 148
Joined: Fri Jul 29, 2005 10:12 am
Location: Johnstown, Pa
Contact:

Post by nate » Tue Sep 06, 2005 3:47 pm

Yes, that would be a general example of like a services Link Block.

You would essentially need something like that for linking services, just make sure your services as I said has the appropriate link name and assign it a unique password, case sensitve.

damousys
Posts: 5
Joined: Tue Sep 06, 2005 1:17 pm
Contact:

Post by damousys » Tue Sep 06, 2005 4:26 pm

owke i did not know that i needed that for a standart installation

damousys
Posts: 5
Joined: Tue Sep 06, 2005 1:17 pm
Contact:

Post by damousys » Tue Sep 06, 2005 4:38 pm

i have put this in my conf file

Code: Select all

link            hub.damousys.nl
{
	username	*;
	hostname 	127.0.0.1;
	bind-ip 	*;
	port 		7029;
	hub             *;
	password-connect "LiNk";
	password-receive "LiNk";
	class           servers;
		options {
			/* Note: You should not use autoconnect when linking services */
			autoconnect;
			zip;
		};

Should that be all because i still receive the same error

damousys
Posts: 5
Joined: Tue Sep 06, 2005 1:17 pm
Contact:

Post by damousys » Tue Sep 06, 2005 5:26 pm

ive got him ive got SNMP runnin so 6667 was occupyed

Darvocet
Posts: 105
Joined: Sun Jun 27, 2004 6:40 am
Location: Houston, TX
Contact:

Post by Darvocet » Tue Sep 06, 2005 8:14 pm

damousys wrote:i have put this in my conf file
Should that be all because i still receive the same error
COuld be that im missing something stupid, but what is the reason in having a link block with a hostname 127.0.0.1. Why are you linking 2 servers that are both on localhost? I'm sure your not, but regardless that makes little sense.
- Darvocet
Sr. Network Admin: EpicIRC.Net

w00t
Posts: 1136
Joined: Thu Mar 25, 2004 3:31 am
Location: Nowra, Australia

Re: Startup probs

Post by w00t » Wed Sep 07, 2005 6:59 am

I'm not sure WHERE this topic is going.. let's go back to the original error.
damousys wrote:[Tue Sep 06 09:24:43 2005] - Error binding stream socket to IP 0.0.0.0 port 6667 - server1.damousys.nl[]:Permission denied
Based on that, I'd guess you've got the default listen block, something like:

Code: Select all

listen *:6667;
That error generally means that you're on a multiple IP machine (ie: a shell account), and you don't have access to what you're trying to bind to. To fix this, give the listen block a specific IP. Ask your service provider which one to use.[/quote]
-ChatSpike IRC Network [http://www.chatspike.net]
-Denora Stats [http://denora.nomadirc.net]
-Omerta [http://www.barafranca.com]

Post Reply