Remote include fail: No file.., ./curl gets file w/o problem

These are old archives. They are kept for historic purposes only.
Post Reply
da127
Posts: 15
Joined: Thu Dec 29, 2005 6:06 am

Remote include fail: No file.., ./curl gets file w/o problem

Post by da127 » Thu Dec 29, 2005 6:25 am

Alright...
Error is "No such file or directory" using curl-compiled version of unrealircd 3.2.3.
When running curl (from HOME/curl/bin/curl) with the same URL as that I included I get the expected .conf from the remote server - no errors.

Curl and c-ares were installed using curlinstall.sh from the stable cvs, however linker still gave me a problem on ./unreal start (libcurl.so.3 not found, required by "ircd") so i forced curl ./configure to run with --enable-shared and set LD_LIBRARY_PATH to HOME/curl/lib.

This has been an ongoing problem attempting to get Unreal's remote includes to work (properly)...

jewles
Posts: 263
Joined: Thu Mar 11, 2004 7:41 pm
Location: Herndon, VA
Contact:

Post by jewles » Thu Dec 29, 2005 2:47 pm

Okay.

What Operating System are you using? I haven't has any errors on compile or running unreal. I am testing it right now and will recheck the script against the older versions. Thank you for letting me know.


[ UPDATED POST ]

I ran both the stable and the latest version of the script and didn't have any noticeable problems. I downloaded a clean version of both directly from the cvs server along with a new version of Unreal3.2 and compiled both without any problems.

It is possible that that script hasn't been tested on your OS (even thou i've tried on every system i can get my hands on) So again if you could please listed your current operating system and version. Thanks....
FBSD-DEV Project
http://www.fbsd-dev.org

YatesDev Hosting
http://www.yatesdev.com

The Wrong Way
http://www.thewrongway.net

da127
Posts: 15
Joined: Thu Dec 29, 2005 6:06 am

OS

Post by da127 » Thu Dec 29, 2005 7:06 pm

FreeBsd 4.11-STABLE is what I installed on, I'm not saying the installer script has any problems I just don't understand why the hell the included file gives me an error on ./unreal start when the curl program in HOME/curl/bin gets the exact same URL without any problem whatsoever.

jewles
Posts: 263
Joined: Thu Mar 11, 2004 7:41 pm
Location: Herndon, VA
Contact:

Post by jewles » Fri Dec 30, 2005 2:10 pm

when you compiled unreal did you compile the curl install path as /home/USER/curl or /home/USER/curl/bin/curl ?? (I'm not even sure weather or not ./Config in unreal would even let you.) but just wondering... Out side of it being a faulty compile. I'm finding it hard to come up with possibilities to why you are having a problem.

I must admit that i'm still unclear as to what the problem you are exactly having is... Maybe if you could possibiily produce this error that would help me figure out where the problem you are having is.
FBSD-DEV Project
http://www.fbsd-dev.org

YatesDev Hosting
http://www.yatesdev.com

The Wrong Way
http://www.thewrongway.net

da127
Posts: 15
Joined: Thu Dec 29, 2005 6:06 am

The problem...

Post by da127 » Sat Jan 07, 2006 4:33 pm

Is that it simply does not work, since I posted this topic I've installed fresh Unreal's with fresh curlinstall scripts and it works fine. I think this is my fix: rm -rf Unreal3.2

Post Reply