/helpop isn't working

These are old archives. They are kept for historic purposes only.
Post Reply
Grunt
Posts: 159
Joined: Mon Jan 09, 2006 7:31 pm
Contact:

/helpop isn't working

Post by Grunt » Thu Jan 12, 2006 2:43 am

Hi. My problem is that I set up the server, but /helpop isn't working. I am oper, I tried to use /helpop ?chmodes, but nothing. I tried connecting as a regular user, but still nothing.

I am using Unreal 3.2.3 and the latest Anope. Configuration file blocks available at request.

Thanks in advance.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Thu Jan 12, 2006 6:24 am

Did you include help.conf?

Grunt
Posts: 159
Joined: Mon Jan 09, 2006 7:31 pm
Contact:

Post by Grunt » Thu Jan 12, 2006 3:11 pm

Yes. These are all the includes:

include "aliases/anope.conf"
include "help.conf";
include "badwords.channel.conf";
include "badwords.message.conf";

On /rehash, i get this:
[17:13] -MyServer- *** Notice -- unrealircd.conf:49: Ignoring extra data

Until now, I thought that line 49 is the anope.conf file, but I did a line counting and it's the help.conf. What does this mean?



Also, I set these:
....
modes-on-join "+nt"
modes-on-connect "+ixw";
....
, but when i connected, it only gave me +i.

Then i disabled modes-on-join, and modes-on-connect worked just fine :?

Dukat
Posts: 1083
Joined: Tue Mar 16, 2004 5:44 pm
Location: Switzerland

Post by Dukat » Thu Jan 12, 2006 3:43 pm

Every line has to end with a ";" :!:
include "aliases/anope.conf";
include "help.conf";
modes-on-join "+nt";
modes-on-connect "+ixw";
If you don't make mistakes, you aren't really trying.
- Coleman Hawkins

Grunt
Posts: 159
Joined: Mon Jan 09, 2006 7:31 pm
Contact:

Post by Grunt » Thu Jan 12, 2006 4:02 pm

Oh. *slaps his forehead*

It was so obvious, and I didn't see it.. Thanks.
Computers are machines that cause trouble you wouldn't normally have if you wouldn't have a computer.

Post Reply