Linking issues

These are old archives. They are kept for historic purposes only.
Post Reply
Kaho
Posts: 5
Joined: Mon Dec 26, 2005 2:42 am

Linking issues

Post by Kaho » Sat Jan 14, 2006 2:46 am

my friend gets this erro [9:31am] <Jagger> * *** Global -- Closing link: Write error: Connection refused - irc.xitz.net[64.235.176.28]
when we trying to link we have ports open and everything

[9:44am] [Xitz] *** Notice -- No response from sakai.xitz.net[70.33.141.133], closing link is what i get

Bricker
Posts: 88
Joined: Tue May 03, 2005 7:31 am
Location: Sterling, VA, USA

Post by Bricker » Sat Jan 14, 2006 3:02 am

place your link blocks from both servers here. CHange passwords/IP's
-Bricker-

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sat Jan 14, 2006 3:14 am

Be sure you have listen blocks for the ports you are linking on

Be sure your ports are valid

Be sure your ports are not marked as client only

Be sure your firewall has the ports open

Be sure the ports are accessable with a normal client

Kaho
Posts: 5
Joined: Mon Dec 26, 2005 2:42 am

Post by Kaho » Sat Jan 14, 2006 4:05 am

link sakai.xitz.net
{
username *;
hostname 70.33.141.133;
bind-ip *;
port 9050;
hub *;
password-connect "password";
password-receive "password";
class servers;
options {
/* Note: You should not use autoconnect when linking services */
autoconnect;
//ssl;
//zip;
};
};

Thats mine heres his


link irc.xitz.net

{

username *;

hostname 64.235.176.28;

bind-ip *;

port 9051;

hub *;

password-connect "password";

password-receive "password";

class servers;

options {

/* Note: You should not use autoconnect when linking services */

autoconnect;

ssl;

//zip;

};

};

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sat Jan 14, 2006 4:07 am

They both either need SSL or not

They should use the same port to simplify things

da127
Posts: 15
Joined: Thu Dec 29, 2005 6:06 am

Post by da127 » Sat Jan 21, 2006 5:54 am

irc.xitz.net needs:

listen 64.235.176.28:9051 {
serversonly;
};

sakai.xits.net needs:

listen 70.33.141.133:9050 {
serversonly;
};

you can check that the servers are listening on the proper ports with:
"netstat -tlan|grep 905."

you might also want to take a look at your ircd.log to see if it gives some insight as to what the problem might be

you should probably also set the bind-ip in your link lines instead of using *

Post Reply