Cloaking

These are old archives. They are kept for historic purposes only.
Post Reply
CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm

Cloaking

Post by CrashOverride »

Hello all, i seem to be having trouble with cloakingi dont want the host name or ip to show i did the opiton 1 in the FAQ

How to disable it?

You have several options:
Option 1: make cloaking not the default
Just remove the 'x' in set::modes-on-connect, then users will not be set +x automatically and thus will not be cloaked.
Users can still, if they want to, set themselves usermode +x.

Option 2: fully deny users to be cloaked If you don't even want users to be cloaked when they want themselves to, in other words: prevent users from setting themselves +x. Then like the previous step, remove 'x' from set::modes-on-connect if it is present, AND set set::restrict-usermodes to 'x':

set { restrict-usermodes "x"; };


And i still seen the ip and host (below)

[ 03:19:16 ] * Syntax` (fdgh@adsl-68-22-206-99.dsl.chcgil.ameritech.net) Quit (Connection reset by peer)

i tried option 2 by adding this

set { restrict-usermodes "x"; };

to the config but i got config error while rehashing.

Also i dl the nocloak modual and tried to load it in the config and got a wrong header error the file was nocloak.c i seen the other moduals had a *.so ending ...am i doing somthing wrong?
Jobe
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe »

Firstly you want cloaking enabled (which hides the IP's) So youll want to leave x in the set::modes-on-connect param.

Secondly youll need to compile the module for it to become a .so file. Im not sure exactly how to compile modules so someone else will have to help you with that.
Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth »

Code: Select all

set { 
  modes-on-connect "x"; 
  restrict-usermodes "x";
};
Will get you hosts like: "rox-254C3118.hsd1.ca.comcast.net"

If that is still too much information, then use:

Code: Select all

set { 
  modes-on-connect "x"; 
  restrict-usermodes "x";
  options { dont-resolve; };
};
Which will tell Unreal to not resolve IPs, and hash them to give everyone hosts like: "DB7ACEA3.AA2380CE.BDFE59AB.IP"

EDIT: Also note, when you rehash, no one already connected will be changed, they would need to reconnect to get the hashed host.

The nocloak module is a module to completely disable cloaking, not to cloak people's IP/host...
Last edited by Stealth on Thu Oct 19, 2006 3:54 pm, edited 1 time in total.
CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm

Post by CrashOverride »

Yes this is what i want, however where do i place that in the config?? Any where, more then a yes would be good :oops:

set {
modes-on-connect "x";
restrict-usermodes "x";
options { dont-resolve; };
};
Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth »

Place that anywhere in your config, which is not in a block (generally people just add it to the end of the config)

Be sure to remove the loadmodule lines for the nocloak module, so you won't have those errors when you rehash
CrashOverride
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm

thanks

Post by CrashOverride »

k thanks
Post Reply