SendQ

These are old archives. They are kept for historic purposes only.
Post Reply
Johndoe
Posts: 3
Joined: Thu Jan 18, 2007 2:33 am

SendQ

Post by Johndoe » Thu Jan 18, 2007 3:04 am

I have read through some of the threads about this here, and I still do not understand what to do to correct it.

I'm running UnrealIRCD 3.2 and anope in Windows.


My problem starts with my services slowing way way down. We type a command, and it will take up to 30 seconds to respond. Eventually, they just shut down and I get this error:

Code: Select all

===	*** Notice -- Max SendQ limit exceeded for services.Almightytoast.no-ip.org[127.0.0.1]: 5000012 > 5000000
[20:58]	===	*** Global -- Closing link: Max SendQ exceeded - services.Almightytoast.no-ip.org[127.0.0.1]
Now, I edit the sendq up in the unrealircd.config looking like this:

Code: Select all

class           clients
{
	pingfreq 90;
	maxclients 500;
	sendq 5000000;
	recvq 1000;
};

class           servers
{
	pingfreq 90;
	maxclients 10;		/* Max servers we can have linked at a time */
	sendq 5000000;
	connfreq 100; /* How many seconds between each connection attempt */
I'm not sure which part is producing the error, clients or servers, I usually just edit both accordingly. Also, when I bump it up to some ridiculous amount, the services end sooner.

I know this is an Unreal forum, but I went to the Anope forum first, and they said it was a problem with Unreal's config. I am obviously new at this, my server just went up yesterday.

Here are the threads I looked at before I posted this:

http://forums.unrealircd.com/viewtopic. ... bufferpool
http://forums.unrealircd.com/viewtopic. ... bufferpool

Jobe1986
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe1986 » Thu Jan 18, 2007 11:48 am

Well the error you posted is almost always a ulines problem as in your services server isnt ulined properly. You MUST add your services server name to the ulines block and it IS case sensitive. For example:

Code: Select all

ulines {
services.invictachat.net;
};

BigBen
Posts: 49
Joined: Sat Nov 25, 2006 3:25 pm

Post by BigBen » Thu Jan 18, 2007 11:05 pm

i got this same thing once, and i was told to do:

ServerName "127.0.0.1" ( in services config )

unreal:

link 127.0.0.1
{
username *;
hostname 127.0.0.1;


ulines {
127.0.0.1;
127.0.0.1;
};

Jobe1986
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe1986 » Fri Jan 19, 2007 2:19 pm

Im pretty sure you wasnt told to name your services server "127.0.0.1" but that must be identical to the link block name and the value in the ulines block (case sensitive)

BigBen
Posts: 49
Joined: Sat Nov 25, 2006 3:25 pm

Post by BigBen » Fri Jan 19, 2007 11:45 pm

or...you can try this:

ircd.conf:
-------------------------

listen 127.0.0.1:6669;

link services.bigtigerirc.net
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 6669;
password-connect "---"; be sure the passwords are the same!
password-receive "---";
class servers;
};

ulines { services.bigtigerirc.net };

set { services-server "services.bigtigerirc.net" };

include "aliases/anope.conf";

-----------
Services:

RemoteServer 127.0.0.1 6669 "----"

# ServerName <name> [REQUIRED]
# Specifies the IRC server name which Services should use. May be
# overridden by the -name command-line option.

ServerName "services.bigtigerirc.net"


# ServerDesc <text> [REQUIRED]
# Specifies the text which should appear as the server's information in
# /whois and similar queries. May be overridden by the -desc
# command-line option.

ServerDesc "Services for IRC Networks"

# ServiceUser <usermask> [REQUIRED]
# Specifies the user@host mask which should be used by the Services
# pseudoclients. May be overridden by the -user and -host command-line
# options.

ServiceUser "services@bigtigerirc.net"

Jobe1986
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe1986 » Sat Jan 20, 2007 12:38 am

BigBen forgot the ; in the ulines block:

Code: Select all

ulines { services.bigtigerirc.net; };

wax
Posts: 72
Joined: Tue Oct 04, 2005 6:32 am
Location: ByNets@Belarus
Contact:

Post by wax » Tue Jan 23, 2007 12:39 pm

100% try to increase sendq in class servers:
for example:

Code: Select all

class           servers 
{ 
   pingfreq 90; 
   maxclients 10;      /* Max servers we can have linked at a time */ 
   sendq 10000000; 
   connfreq 100; /* How many seconds between each connection attempt */
if not help and erroe be the same - increase this value while not gor error :P

Jobe1986
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe1986 » Tue Jan 23, 2007 4:58 pm

wax, if it is ulines, increasing the sendq will only delay the disconnect a little longer.

wax
Posts: 72
Joined: Tue Oct 04, 2005 6:32 am
Location: ByNets@Belarus
Contact:

Post by wax » Tue Jan 30, 2007 6:30 am

Jobe1986 wrote:wax, if it is ulines, increasing the sendq will only delay the disconnect a little longer.
no :P
I've got what error in my network and it helps :P

Post Reply