Win32 VS8 NMAKE Compile error (Not Symbols File)

These are old archives. They are kept for historic purposes only.
Post Reply
xnemesis
Posts: 7
Joined: Sun Feb 04, 2007 9:36 pm

Win32 VS8 NMAKE Compile error (Not Symbols File)

Post by xnemesis » Sun Feb 04, 2007 9:52 pm

Ok, I dislike windows but it seems I'm being forced to run Unreal on Windows on one machine. I want to compile the whol kitten kaboodle with remote includes and all.
I trying to compile with this command:

Code: Select all

nmake -f makefile.win32 USE_ZIPLINKS=1 ZLIB_INC_DIR="c:\dev\zlib-1.2.3" ZLIB_LIB_DIR="c:\dev\zlib-1.2.3\dll32" USE_SSL=1 OPENSSL_INC_DIR="c:\dev\openssl-0.9.8d\include" OPENSSL_LIB_DIR="c:\dev\openssl-0.9.8d\lib" USE_REMOTEINC=1 LIBCURL_INC_DIR="c:\dev\curl-7.16.0\include" LIBCURL_LIB_DIR="c:\dev\curl-7.16.0\lib"
And I get the following error:

Code: Select all

/out:config.exe
config.obj
             link /debug advapi32.lib src/unreal.obj src/win32/unreal.res
Microsoft (R) Incremental Linker Version 8.00.50727.762
Copyright (C) Microsoft Corporation. All rights reserved.

src/unreal.obj : fatal error LNK1107: invalid or corrupt file: cannot read at 0x270A
NMAKE : fatal error U1077: 'link' : return code '0x453'
Stop.
I've done a fair amount of rooting and tried various things to no avail.
I'm using MS Visual Studio 8 (2005 .net express). Running in platform SDK Windows XP 32-Bit IE 5.5 RETAIL Build Environment. And apologies if this has already been answered I couldn't find a similar enough problem myself.

Many Thanks.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sun Feb 04, 2007 10:36 pm

Your answer is in the FAQ...

xnemesis
Posts: 7
Joined: Sun Feb 04, 2007 9:36 pm

Post by xnemesis » Sun Feb 04, 2007 10:38 pm

I presume you are referring to Symbol Files? That's not my solution. I tried that prior to posting.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Mon Feb 05, 2007 5:02 am

I'm not sure VS 8 is fully compatible with Unreal yet, you'd need to use VS 7.x

xnemesis
Posts: 7
Joined: Sun Feb 04, 2007 9:36 pm

Post by xnemesis » Mon Feb 05, 2007 10:51 am

Ok I'll take a look. All the documentation seems to suggest that it is but it's not tested. I'll post back my results :)

xnemesis
Posts: 7
Joined: Sun Feb 04, 2007 9:36 pm

Post by xnemesis » Mon Feb 05, 2007 11:07 am

Anyone have a link by chance to VC or VS 2002/3 (7.x) I cannot find a download of it on Microsofts site (I'm looking for express)

Post Reply