Page 1 of 1

unreal not started

Posted: Wed Dec 17, 2008 7:35 am
by FiGhTeRs
please help


[fighters@ns unreal]$ sh ./unreal start
Starting UnrealIRCd
Possible error encountered (IRCd seemingly not started)
=====================================================
Check above for possible errors, and this output of
ircd.log. If you cannot solve the problem, read
Unreal.nfo on where to get support
=====================================================
[fighters@ns unreal]$

and nothing writing in ircd.log

--------------------------------------------------------------------------------------------------------------
my configuratiion
---------------------------


| Compile is now complete. |
| You should now read the documentation and learn |
| how to configure your IRCd. |
| |
| If you really like UnrealIRCd, and would like to |
| make a donation, please read the Donation file in|
| this archive. :) |
| |
| Thanks for using Unreal IRCd! If you are in need |
| for any kind of help regarding the IRCd please |
| read the Unreal.nfo file. |
|__________________________________________________|


i make & make all finished

my config file unrealircd.conf is:

Code: Select all

me {
	name ns.ele.lt;
	info Mx-3 Network;
	numeric 1;

admin {
	"Renatas";
	"FiGhTeRs";
	"fighters@mx-3.lt";
};

class clients {
	pingfreq 90;
	maxclients 500;
	sendq 100000;
	recvq 8000;
};

class servers {
	pingfreq 90;
	maxclients 10; /* Max servers we can have linked at a time */
	sendq 1000000;
	connfreq 100; /* How many seconds between each connection attempt */
};


allow {
	ip *;
	hostname *;
	class clients;
	maxperip 5;
};

allow {
	ip *@*;
	hostname *@*.passworded.ugly.people;
	class clients;
	password "testas";
	maxperip 1;
};


listen *:6601 {
	options {
		ssl;
		clientsonly;
	};
};


drpass {
	restart "testas";
	die "testas";
};


loadmodule "src/modules/commands.so";
loadmodule "src/modules/cloak.so";


og ircd.log {
	maxsize 5MB;
	flags {
		errors;
		kills;
		oper;
		kline;
		tkl;
	};
};


set {
	kline-address info@mx-3.lt;
	auto-join #Mx-3;
	options {
		hide-ulines;
	};
	hosts {
		local localhost;
		global ns.ele.lt;
	};
};

Re: unreal not started

Posted: Wed Dec 17, 2008 12:09 pm
by T-rexke

Code: Select all

me {
   name ns.ele.lt;
   info Mx-3 Network;
   numeric 1;


put 2 " to like this:

Code: Select all

me {
   name "ns.ele.lt";
   info "Mx-3 Network";
   numeric 1;
second:

Code: Select all

allow {
   ip *;
   hostname *;
   class clients;
   maxperip 5;
};
chang to this:

Code: Select all

allow {
   ip *@*;
   hostname *@*;
   class clients;
   maxperip 5;
};
and you are missing a lot of blocks i geuss

Re: unreal not started

Posted: Wed Dec 17, 2008 1:24 pm
by [dx]
FiGhTeRs wrote: and nothing writing in ircd.log

Code: Select all

og ircd.log {
	maxsize 5MB;
	flags {
		errors;
		kills;
		oper;
		kline;
		tkl;
	};
};
It must be LOG, not OG

Re: unreal not started

Posted: Thu Dec 18, 2008 12:36 pm
by T-rexke
yes change it to log and the give us the log reply then its much easyer to help

Re: unreal not started

Posted: Thu Dec 18, 2008 10:51 pm
by FiGhTeRs
[dx] wrote:
FiGhTeRs wrote: and nothing writing in ircd.log

Code: Select all

og ircd.log {
	maxsize 5MB;
	flags {
		errors;
		kills;
		oper;
		kline;
		tkl;
	};
};
It must be LOG, not OG
i fixed this mistake, but log not writed

log ircd.log {
maxsize 5MB;
flags {
errors;
kills;
oper;
kline;
tkl;
connects;
server-connects;
sadmin-commands;
chg;
oper-override;
spamfilter;
};
};

Re: unreal not started

Posted: Fri Dec 19, 2008 7:12 am
by zEkE
Check your user permissions (user and group ownership, as well as read/write/execute) for both Unreal folder and ircd.log (if exists).

Assuming you didn't install Unreal as a different user to that which you are running from?