Page 1 of 1

For /whois information

Posted: Wed Feb 04, 2009 4:13 pm
by siaosiaokia
Hi!

How do you I set the whois output to show whether is the nick registered or not?

For example:
Original:
Testuser is TestUser@Test.IP* TestUser
Testuser on #test
Testuser using test.localhost.com test.localhost.com
Testuser has been idle 1sec, signed on Wed Feb 04 21:46:50
Testuser End of /WHOIS list.
Desired Result:
Testuser is TestUser@Test.IP* TestUser
Testuser on #test
Testuser is a registered nick
Testuser using test.localhost.com test.localhost.com
Testuser has been idle 1sec, signed on Wed Feb 04 21:46:50
Testuser End of /WHOIS list.

Re: For /whois information

Posted: Wed Feb 04, 2009 5:49 pm
by Casper
You can achieve that by giving your users the opportunity to register with a services package.

Re: For /whois information

Posted: Thu Feb 05, 2009 5:03 am
by zEkE
The other answer is that that line is controlled by user mode +r. If you have +r (typically given by Nickserv upon registering/identifying), that line will appear in your whois reply.

Re: For /whois information

Posted: Thu Feb 05, 2009 8:28 am
by Casper
zEkE wrote:The other answer is that that line is controlled by user mode +r. If you have +r (typically given by Nickserv upon registering/identifying), that line will appear in your whois reply.
I don't think he wants to do that on every user connection to the server :')

Re: For /whois information

Posted: Thu Feb 05, 2009 1:44 pm
by siaosiaokia
Yeah, I have the services running.

However, I uses UseSVS2MODE with unreal 3.2. But it is still missing that line.

It seems like the usermode is without +r.

How do I set +r for usermode everytime they have successfully identify their nick?

Thanks!

Re: For /whois information

Posted: Thu Feb 05, 2009 4:53 pm
by Casper
What services are you using?

Re: For /whois information

Posted: Fri Feb 06, 2009 4:08 pm
by siaosiaokia
Casper wrote:What services are you using?
Anope.

Re: For /whois information

Posted: Fri Feb 06, 2009 4:37 pm
by [dx]
Well, check if your nick is registered and identified to services.

/ns info nick

Re: For /whois information

Posted: Sun Feb 08, 2009 3:11 am
by siaosiaokia
Yeah, it wrote:

Time registered: Jan 30 22:56:08 2009 PST

Re: For /whois information

Posted: Sun Feb 08, 2009 4:58 am
by zEkE
The question then, is the nick identified?

zEkE is a registered nick, but is not currently online or is not currently identified.
[23:56:17] -NickServ- zEkE is http://bananabiter.wordpress.com/
[23:56:18] -NickServ- zEkE is a services root administrator.
[23:56:18] -NickServ- Time registered: Aug 28 18:58:34 2007 EDT
[23:56:18] -NickServ- Last seen time: Feb 06 16:55:26 2009 EST
[23:56:18] -NickServ- Last quit message: Broken pipe
[23:56:18] -NickServ- For more verbose information, type /msg NickServ INFO zEkE ALL.
zEkE|Macbook however, is online and identified.
[23:56:25] -NickServ- zEkE|Macbook is http://bananabiter.wordpress.com/
[23:56:26] -NickServ- zEkE|Macbook is a services root administrator.
[23:56:26] -NickServ- zEkE|Macbook is currently online.
[23:56:26] -NickServ- Time registered: Dec 27 19:18:43 2008 EST
[23:56:26] -NickServ- Last quit message: Ping timeout
[23:56:26] -NickServ- For more verbose information, type /msg NickServ INFO zEkE|Macbook ALL.

Re: For /whois information

Posted: Sun Feb 08, 2009 5:02 am
by siaosiaokia
-NickServ- Q is Q
-
-NickServ- Q is a services root administrator.
-
-NickServ- Q is currently online.
-
-NickServ- Time registered: Jan 30 09:25:44 2009 PST
-
-NickServ- Last quit message: Ping timeout
I have already identified the nick.

Re: For /whois information

Posted: Mon Feb 09, 2009 9:58 am
by Jobe
This sounds like your ulines are incorrect.

Make sure you have youe Anope server name listed in your ulines block on ALL servers, rehash them all then restart Anope.

Re: For /whois information

Posted: Thu Feb 12, 2009 6:32 am
by siaosiaokia
Jobe1986 wrote:This sounds like your ulines are incorrect.

Make sure you have youe Anope server name listed in your ulines block on ALL servers, rehash them all then restart Anope.
Thanks for the help!
Yeah, there is a typo with the ulined server name.