Global IRCop Woes

These are old archives. They are kept for historic purposes only.
Post Reply
Master007
Posts: 3
Joined: Wed Feb 18, 2009 2:20 am

Global IRCop Woes

Post by Master007 » Wed Feb 18, 2009 2:24 am

Hello,
I have been trying to add myself as a Global IRCop and full admin, basically every thing you can be.
I've added a bunch of flags in conf/oper.conf arranged as so:

Code: Select all

oper Master007 {
        class           clients;
        from {
                userhost *@*;
        };
        password "***";
        flags{
                local;
                global;
                admin;
                services-admin;
                netadmin;
                can_localkill;
                can_globalkill;
                can_kline;
                can_unkline;
                can_zline;
                can_gkline;
                can_setq;
                can_override;
        };

        swhois "Master007";
        snomask ***;
        modes   pqWH;
};
Can someone please direct me on what I am doing wrong because when I try /oper, it says that I am not on the O:Line list.
Thanks in advance! :)

digi198816
Posts: 33
Joined: Sat Apr 12, 2008 7:02 pm
Location: Brampton, Ontario

Re: Global IRCop Woes

Post by digi198816 » Wed Feb 18, 2009 2:39 am

Make sure you are using right user/password. so it should be /oper Master007 (capital M) and password. Make sure u mind the capital/small letters since its case sensitive.

Master007
Posts: 3
Joined: Wed Feb 18, 2009 2:20 am

Re: Global IRCop Woes

Post by Master007 » Wed Feb 18, 2009 2:57 am

I'm typing everything in right, pretty sure about that. :wink:

digi198816
Posts: 33
Joined: Sat Apr 12, 2008 7:02 pm
Location: Brampton, Ontario

Re: Global IRCop Woes

Post by digi198816 » Wed Feb 18, 2009 3:46 am

Did you /rehash after editing?

Casper
Posts: 338
Joined: Sun Jul 08, 2007 7:44 am
Location: The Netherlands

Re: Global IRCop Woes

Post by Casper » Wed Feb 18, 2009 6:46 pm

And, since you've created a separate file for your opers, have you included conf/oper.conf in the unrealircd.conf ?

Code: Select all

include "conf/oper.conf";
Ex Network-Administrator

Master007
Posts: 3
Joined: Wed Feb 18, 2009 2:20 am

Re: Global IRCop Woes

Post by Master007 » Thu Feb 19, 2009 12:04 am

Thanks, I've rehashed it and restarted everything but still nothing.
I also checked unrealircd.conf and it is including oper.conf; I didn't create this, it was automatically created.
So I'm thinking its a problem with my code in the configuration file; I've redid it so everything is like this:
flags "admin";
flags "can_setq";
etc.

but still nothing. :(

digi198816
Posts: 33
Joined: Sat Apr 12, 2008 7:02 pm
Location: Brampton, Ontario

Re: Global IRCop Woes

Post by digi198816 » Thu Feb 19, 2009 1:15 am

Can you post your unrealircd.conf (the include part for oper.conf) , and thats weird :S perhaps try your real host or if you can, restart the server.

Jobe1986
Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Re: Global IRCop Woes

Post by Jobe1986 » Thu Feb 19, 2009 1:55 pm

Not sure if it matetrs or not, but from your first post, make sure there is a space between flags and { so "flags{" should be "flags {"

Then on your shell type ./unreal rehash
Your IP: Image

Skizzerz
Posts: 16
Joined: Thu Dec 25, 2008 1:39 am

Re: Global IRCop Woes

Post by Skizzerz » Tue Feb 24, 2009 3:52 am

One thing I noticed is that you are including the "local," "global," etc. flags. Since the "netadmin" flag includes all of those flags, remove the local, global, admin, and services-admin flags (keep the netadmin flag) -- not only are they unnecessary but it might be causing an issue with the oper block not getting recognized or something.

Alb4
Posts: 3
Joined: Sat Feb 26, 2011 11:06 am

Re: Global IRCop Woes

Post by Alb4 » Sat Feb 26, 2011 11:58 am

Code: Select all

* Loading IRCd configuration ..
* oper.conf:26: Ignoring extra close brace
* oper.conf:26 Ignoring extra semicolon
[error] oper.conf:7: Unknown directive 'oper::flags{'
[error] oper.conf:9: oper::global specified without a value
[error] oper.conf:10: oper::admin specified without a value
[error] oper.conf:11: oper::services-admin specified without a value
[error] oper.conf:12: oper::netadmin specified without a value
[error] oper.conf:13: oper::can_localkill specified without a value
[error] oper.conf:14: oper::can_globalkill specified without a value
[error] oper.conf:15: oper::can_kline specified without a value
[error] oper.conf:16: oper::can_unkline specified without a value
[error] oper.conf:17: oper::can_zline specified without a value
[error] oper.conf:18: oper::can_gkline specified without a value
[error] oper.conf:19: oper::can_setq specified without a value
[error] oper.conf:20: oper::can_override specified without a value
[error] oper.conf:1: oper::flags is missing
* oper.conf:23: unknown directive swhois
* oper.conf:24: unknown directive snomask
* oper.conf:25: unknown directive modes
[error] 14 errors encountered
[error] IRCd configuration failed to pass testing
Possible error encountered (IRCd seemingly not started)
Help Please !

katsklaw
Official supporter
Posts: 1114
Joined: Sun Apr 18, 2004 5:06 pm

Re: Global IRCop Woes

Post by katsklaw » Sat Feb 26, 2011 2:48 pm

* oper.conf:26: Ignoring extra close brace
* oper.conf:26 Ignoring extra semicolon


You have an extra close brace and semi-colon just above line 26. I know there are other errors listed. However, the easiest way is to start at the top of the list and fix them one at a time. It's possible to have 500 errors and they all be fixed with 1 missing character. So start at the top and work your way down.

Post Reply