Problem with static quit

These are old archives. They are kept for historic purposes only.
Post Reply
Izv143
Posts: 17
Joined: Fri Feb 13, 2009 11:50 pm

Problem with static quit

Post by Izv143 » Mon Mar 02, 2009 11:08 am

How to fix this problem with static quit? In unrealircd.conf looks like this:
/* Make the message in static-quit show in all quits - meaning no
custom quits are allowed on local server */
/*static-quit "Quit";*/


and when somebody quit from the server it says his/hers nickname in quit msg, I'd like to change that to be custom quits where users can choose their quit msg,
anybody could help pls ??

Casper
Posts: 338
Joined: Sun Jul 08, 2007 7:44 am
Location: The Netherlands

Re: Problem with static quit

Post by Casper » Mon Mar 02, 2009 12:32 pm

I guess they're using some sort of java chat or something. Only when your users type '/quit msg' there will be a message shown, otherwise just "(Quit: )" or in your case the nickname in it.
Ex Network-Administrator

Izv143
Posts: 17
Joined: Fri Feb 13, 2009 11:50 pm

Re: Problem with static quit

Post by Izv143 » Wed Mar 04, 2009 9:37 am

Casper they're using PJIRC as java chat but if u use mIRC on the server or any other IRC client and type /quit bye bye it does not show this bye bye it just shows nickname of the user, something like this ( * Guest (Guest@user-8399BEB5.ipt.aol.com) Quit (Quit: Guest)
but quit msg should be bye bye

Casper
Posts: 338
Joined: Sun Jul 08, 2007 7:44 am
Location: The Netherlands

Re: Problem with static quit

Post by Casper » Wed Mar 04, 2009 12:26 pm

Then the configuration of the Java PJIRC chat is overriding the /quit <text>. Check your settings!
Ex Network-Administrator

Izv143
Posts: 17
Joined: Fri Feb 13, 2009 11:50 pm

Re: Problem with static quit

Post by Izv143 » Thu Mar 05, 2009 11:16 am

Casper wrote:Then the configuration of the Java PJIRC chat is overriding the /quit <text>. Check your settings!
Can't be problem in PJIRC and mIRC and anyother mIRC Script like ( Scoop, Extreme etc.) same thing with users who using X Chat or KvIRC. QUIT msg is still same /quiting nickname
If I reinstall Unreal that may solve the problem ???

zEkE
Posts: 111
Joined: Wed Apr 14, 2004 9:30 am
Location: Harrisonburg, VA
Contact:

Re: Problem with static quit

Post by zEkE » Thu Mar 05, 2009 6:58 pm

Check your set block:

Code: Select all

set::anti-spam-quit-message-time <timevalue>;
A time value specifying the length of time a user must be connected for before a /quit message will be displayed. Used to prevent spam. A time value is a numeric string with d meaning days, h meaning hours, m meaning minutes, and s meaning seconds, for example 1d2h3m means 1 day, 2 hours, 3 minutes.
the anti-spam quit message time is used, as stated, to prevent spam. This is usually a number that is long enough to prevent join-part/quit spammers from spamming their quit messages effectively, and short enough that it doesn't block quit messages of legitimate users who have been online a suitable length of time. Most places have it in the region of 10-30 seconds, sometimes up to 2 minutes (just ballpark figures).

A static-quit wouldn't manifest in this way, because a static quit is just that - static. This is dynamic, it changes based on the nickname quitting.
NetAdmin - irc.unitedchristianchat.net
http://www2.i-al.net/ircbots/

Izv143
Posts: 17
Joined: Fri Feb 13, 2009 11:50 pm

Re: Problem with static quit

Post by Izv143 » Fri Mar 06, 2009 8:30 am

This is set block

maxchannelsperuser 10;
/* The minimum time a user must be connected before being allowed to use a QUIT message,
* This will hopefully help stop spam */
anti-spam-quit-message-time 30s;
/* Make the message in static-quit show in all quits - meaning no
custom quits are allowed on local server */
/*static-quit "Quit";*/

and still when someone wants to do like /quit see ya it says this Guest (Guest@user-8399BEB5.ipt.aol.com) Quit (Quit: Guest) instead
Guest (Guest@user-8399BEB5.ipt.aol.com) Quit (Quit:see ya)

Post Reply