Problem with Unreal 3.2 and Anope permissions.

These are old archives. They are kept for historic purposes only.
Post Reply
bluewish
Posts: 5
Joined: Tue Jan 27, 2009 11:45 am

Problem with Unreal 3.2 and Anope permissions.

Post by bluewish » Wed May 06, 2009 9:41 am

Hello. I am running Unreal3.2, with Anope 1.8.0.
I try and use certain commands and they're not working.

The commands that don't work are "SA" commands, /hostserv and /operserv.

I am netadmin of the server, and my modes are:
»» [dan] is using modes +iowghrAsxqvt +kcfvGqso

Does anyone know what the problem could be?

zEkE
Posts: 111
Joined: Wed Apr 14, 2004 9:30 am
Location: Harrisonburg, VA
Contact:

Re: Problem with Unreal 3.2 and Anope permissions.

Post by zEkE » Wed May 06, 2009 4:50 pm

Do you get any error messages?
NetAdmin - irc.unitedchristianchat.net
http://www2.i-al.net/ircbots/

seraphim
Posts: 36
Joined: Tue Apr 03, 2007 11:10 am

Re: Problem with Unreal 3.2 and Anope permissions.

Post by seraphim » Wed May 06, 2009 5:09 pm

did you use

include "aliases/anope.conf";

at unrealircd.conf?

zEkE
Posts: 111
Joined: Wed Apr 14, 2004 9:30 am
Location: Harrisonburg, VA
Contact:

Re: Problem with Unreal 3.2 and Anope permissions.

Post by zEkE » Wed May 06, 2009 5:23 pm

HostServ/OperServ etc sounds like an alias issue - thats why I'm interested to know what error messages are received. If it's a "No such command", the aliases aren't loaded correctly. Anything else and theres a deeper issue.

The /SA* commands are likely caused by your lack of usermode +a, which while given to you at /oper (as a netadmin), looks like anope is probably removing it.

See the config file for anope, particularly:
# UnRestrictSAdmin [OPTIONAL]
# On many ircd Anope removes the umode of +a from users whom are not
# Service Admin in Anope. This mode is NOT used by Anope for any form
# of access. Thus this option allows them to keep the mode without having
# to be a Service Admin in Anope
UnRestrictSAdmin
(It is probably commented - uncomment it and reload/restart Anope, then reconnect/reoper/reidentify and see if /sa* still fails)
NetAdmin - irc.unitedchristianchat.net
http://www2.i-al.net/ircbots/

Post Reply