Aliases are not working.

These are old archives. They are kept for historic purposes only.
Post Reply
Joey
Posts: 8
Joined: Thu Jul 29, 2010 4:13 pm

Aliases are not working.

Post by Joey » Tue Aug 03, 2010 5:15 pm

hello,

i have tryed adding an alias so i can use /bs and it fowards to /botserv however after rehashing the server i get this error when doing any /bs command:
BS Unknown Command.

Here is the code i added;

alias "bs" {
target "botserv";
type services;
spamfilter no;
};

its bound to be wrong... i just dont know how to do it right...

katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Aliases are not working.

Post by katsklaw » Tue Aug 03, 2010 5:24 pm

It's easier to just load the pre-made aliases that come with Unreal, look in the aliases directory for your services package then just include them in your unrealircd.conf and make sure set::services-server is pointing to the correct name for your services, case sensitive.

Joey
Posts: 8
Joined: Thu Jul 29, 2010 4:13 pm

Re: Aliases are not working.

Post by Joey » Tue Aug 03, 2010 5:31 pm

alias bs {
format "^#" {
target botserv;
type services;
parameters "%1-";
};
format "^[^#]" {
target botserv;
type services;
parameters "%1-";
};
type command;
};

Same Error: BS Unknown Command (After Rehashing)

Joey
Posts: 8
Joined: Thu Jul 29, 2010 4:13 pm

Re: Aliases are not working.

Post by Joey » Tue Aug 03, 2010 6:26 pm

Anyone going to help :roll:

katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Aliases are not working.

Post by katsklaw » Tue Aug 03, 2010 7:57 pm

1> waiting only an hour before begging for help again doesnt do any good, we are volunteers that help in our spare time from our day jobs.
2> You should do as I asked before asking for more help, otherwise others will see it as a waste of time, just like I'm about to do.

Joey
Posts: 8
Joined: Thu Jul 29, 2010 4:13 pm

Re: Aliases are not working.

Post by Joey » Tue Aug 03, 2010 8:05 pm

It's easier to just load the pre-made aliases that come with Unreal, look in the aliases directory for your services package then just include them in your unrealircd.conf and make sure set::services-server is pointing to the correct name for your services, case sensitive.
#
ive never realy understood things like set::services-server, what is it all meaning

katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Aliases are not working.

Post by katsklaw » Tue Aug 03, 2010 8:10 pm

Then you should say you don't understand instead of just pasting more stuff that looks like you aren't paying attention. We aren't mind readers either, you know.

1> Read the example #2 at: http://www.unrealircd.com/files/docs/un ... edirective
2> insure that the services-server directive in the set block points to the actual name of your services.

static-x
Posts: 28
Joined: Sat Jul 23, 2005 2:43 am

Re: Aliases are not working.

Post by static-x » Wed Aug 04, 2010 3:33 am

/* Standard Aliases */


alias Nickserv { type services; };
alias ChanServ { type services; };
alias HelpServ { type services; };
alias BotServ { type services; };
alias OperServ { type services; };
alias Memoserv { type services; };





/* Aliases */

alias "ns" {
nick "nickserv";
type services;
};

alias "cs" {
nick "chanserv";
type services;
};


alias "ms" {
nick "memoserv";
type services;
};


alias "bs" {
nick "botserv";
type services;
};

alias "os" {
nick "operserv";
type services;
};
alias "hs" {
nick "hostserv";
type services;
};

Post Reply