Error during make with 3.2.10 on OpenBSD 5.2

These are old archives. They are kept for historic purposes only.
Post Reply
Numbers
Posts: 4
Joined: Wed Jan 02, 2013 3:32 pm

Error during make with 3.2.10 on OpenBSD 5.2

Post by Numbers »

I'm using a fresh install of OpenBSD 3.9 architecture i386 using all of the defaults provided in ./Config

This is the output provided using make > makelog

Code: Select all

Building src
gcc -I../include -I/home/Unreal3.2.10/extras/regexp/include -I/home/Unreal3.2.10/extras/c-ares/include -pipe -g 02 -funsigned-char -fno-strict-aliasing -export-dynamic -c s_bsd.c
*** Error code 1

Stop in /home/Unreal3.2.10/src (line 192 of Makefile).
*** Error code 1

Stop in /home/Unreal3.2.10 (line 149 of Makefile).
While make is progressing there are lots of errors like this one:

Code: Select all

/usr/include/ctype.h:98: error: syntax error before '<' token
There's tens of these errors that fly by that aren't captured by redirecting output. Not sure how to capture those so I can read it properly.

I was originally using OpenBSD 5.2 when getting the exact same errors during make. I installed with OpenBSD 3.9 as listed under Tested & Supported just to make sure.

If anyone can point me in the right direction or maybe where I can look for more information I would be grateful.

Thank you

Mod Note: Changed subject to reflect Open BSD version 5.2 as same error occurs on their latest stable release. -katsklaw
katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Error during make with 3.2.10 on OpenBSD 3.9

Post by katsklaw »

1> Why would you roll so far back to 3.9?? If you are getting the same errors on 5.2 then lets work on that instead.
2> Did you upgrade from 3.2.8.1 or 3.2.9?
3> Has Unreal ever worked for you on OpenBSD or are you a new Unreal user?
Numbers
Posts: 4
Joined: Wed Jan 02, 2013 3:32 pm

Re: Error during make with 3.2.10 on OpenBSD 3.9

Post by Numbers »

I used 3.9 because it was the latest version of OpenBSD listed as Tested and Supported on the documents page listed here http://www.unrealircd.com/files/docs/unreal32docs.html

I did not upgrade

I'm a new Unreal user

I'll be happy to upgrade OpenBSD up to 5.2 again if you think that'll help or be easier to test with
katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Error during make with 3.2.10 on OpenBSD 3.9

Post by katsklaw »

It's best to use the latest OS with the latest Unreal as things can change that inadvertently drops support for older OS's. If you read the versions on the OS's supported, they are all older so it seems the list applies to older versions of Unreal. There are literally hundreds of differences between even 3.2.8 and 3.2.10.

I've just installed OpenBSD 5.2 and will look at it a bit and see if I can find the problem.
Numbers
Posts: 4
Joined: Wed Jan 02, 2013 3:32 pm

Re: Error during make with 3.2.10 on OpenBSD 3.9

Post by Numbers »

Thank you for your efforts. Please let me know if there's anything I can do to help. I installed OpenBSD 5.2 using all of the defaults provided and the only modifications I made in 3.9 were to the partition sizes. Instead of upgrading to 5.2 I'll reinstall with defaults so we're on the same page.
katsklaw
Official supporter
Posts: 1124
Joined: Sun Apr 18, 2004 5:06 pm
Contact:

Re: Error during make with 3.2.10 on OpenBSD 5.2

Post by katsklaw »

As I thought, looks like a bug in the new poll I/O Socket engine support added in 3.2.10. I got 3.2.9 to compile correctly though so use it until a fix is available.

Bug report: http://bugs.unrealircd.org/view.php?id=4155
3.2.9: http://www.unrealircd.com/downloads/Unreal3.2.9.tar.gz
Numbers
Posts: 4
Joined: Wed Jan 02, 2013 3:32 pm

Re: Error during make with 3.2.10 on OpenBSD 5.2

Post by Numbers »

Thanks, that should've been obvious to try after trying a previous version of OpenBSD. Thanks for your help and I'll use 3.2.9 and look out for 3.2.11
Post Reply