Page 1 of 1

Problems linking from ipv6 compile to ipv4 compile

Posted: Mon Feb 04, 2013 9:52 am
by KeyszerS
I've recently downloaded and compiled Unreal3.2.10 on FreeBSD 9.0-RELEASE-p3, and it all appears to be working except for when I need to link it to a server that only has IPv4 support (and conversely, has been compiled without IPv6 support)

This is my current listen blocks and link (note: hostnames, IP's and passwords have been modified for security reasons)

Code: Select all

listen *:6667 {
        options {
                clientsonly;
        };
};

listen *:6697 {
        options {
                ssl;
                clientsonly;
        };
};

listen *:6800 {
        options {
                ssl;
                serversonly;
        };
};

link captain.proton.voy {
        username *;
        hostname 100.90.80.70;
        bind-ip *;
        port 6800;
        hub *;
        password-connect "captainproton";
        password-receive "captainproton";
        class servers;
        options {
                ssl;
                zip;
                #autoconnect;
        };
};
Using this configuration, when linking, I get the following error:
[13/02/04 10:04:10] -buster.kincade.voy- Connect to host captain.proton.voy[::ffff:100.90.80.70] failed: Invalid argument
The FAQ - which lists this error, and suggests the following:


If you get an "invalid argument" error when trying to connect (either via /connect or autoconnect) then you could be experiencing an odd-unreal-behavior-issue.

Fix: specify the IP to bind to in bind-ip inside your link block (eg: "1.2.3.4" instead of "*"), use the IP of the box itself here [not the one to connect to!] ;).

Another way to fix: reorder your listen lines (eg: move the top one to the bottom, etc) and restart the ircd, see if that helps.



I made the necessary changes, my config now looks like this:

Code: Select all

listen 90.80.70.60:6800 {
        options {
                ssl;
                serversonly;
        };
};

listen *:6667 {
        options {
                clientsonly;
        };
};

listen *:6697 {
        options {
                ssl;
                clientsonly;
        };
};

link captain.proton.voy {
        username *;
        hostname 100.90.80.70;
        bind-ip 90.80.70.60;
        port 6800;
        hub *;
        password-connect "captainproton";
        password-receive "captainproton";
        class servers;
        options {
                ssl;
                zip;
                #autoconnect;
        };
};
Upon restarting, and attempting to link, I get new errors, as follows:
[13/02/04 10:29:03] -buster.kincade.voy- error binding to local port for captain.proton.voy[::ffff:100.90.80.70]:Can't assign requested address
[13/02/04 10:29:03] -buster.kincade.voy- *** Couldn't connect to captain.proton.voy.
I can verify that netstat shows the server listening on the applicable IP's and protocols as per the various listen lines.

Does anybody have any other suggestions for me to try?

Re: Problems linking from ipv6 compile to ipv4 compile

Posted: Thu Feb 07, 2013 4:09 pm
by Jobe1986
You mention one of the servers is on FreeBSD,but what OS is the other on?

Re: Problems linking from ipv6 compile to ipv4 compile

Posted: Sat Feb 16, 2013 9:50 am
by KeyszerS
The other server is running FreeBSD 8.

The other server isn't the issue - the connection attempt isn't even made. If I specify a different IP for the target server, I get the same error, so I know it's not the other server which is at fault.

Sorry for late reply have been hecticly busy at work :( For now I've recompiled without ipv6 support, but I can always throw up another IRC network for testing purposes, if somebody is able to work with me on this issue.

Re: Problems linking from ipv6 compile to ipv4 compile

Posted: Sat Feb 16, 2013 7:08 pm
by Syzop
Do incoming IPv4 connections work on the server doing the connect (the source server)?
If not, then it would mean the ircd is currently 'IPv6 only', which would explain why outgoing IPv4 connects also fail to work. In that case, follow the two tweaks suggested in FAQ: Running - IPv6: I have compiled with IPv6, but can't get it to listen at IPv4 addresses.

If incoming IPv4 connections are accepted on the source IPv6 server (and thus you can be sure the IRCd works with both IPv4 and IPv6 clients) then I'm out of ideas... for now.

Re: Problems linking from ipv6 compile to ipv4 compile

Posted: Sun Feb 17, 2013 6:28 pm
by KeyszerS
Yes, incoming IPv4 connections work, clients and servers alike. From the server I would like to link to, it is possible to estalbish a link from that server instead.

If you would like I would be more than happy to give you (Syzop) an account on my FreeBSD box so that you can install and play around with it - at least it gives you something you can play with, and perhaps even find a resolution to the problem (as it may be a bug or interoperability issue with FreeBSD) 9 :)

Re: Problems linking from ipv6 compile to ipv4 compile

Posted: Wed Feb 20, 2013 9:17 pm
by Syzop
Could you report this on http://bugs.unrealircd.org/ ?