Unreal3.2.10.4 not accepting OpenSSL

These are old archives. They are kept for historic purposes only.
Post Reply
Landslyde
Posts: 21
Joined: Mon Jun 23, 2014 6:45 pm

Unreal3.2.10.4 not accepting OpenSSL

Post by Landslyde » Sun Jun 14, 2015 1:36 am

Apparently you do not have both the openssl binary and openssl development libraries installed.
You have two options:
a) Install the needed binaries and libraries
and run ./Config
OR
b) If you don't need SSL...
Run ./Config and say 'no' when asked about SSL
(or pass --disable-ssl to ./configure)
==========================================================================
My server crashed and I reinstalled the OS, Debian 8. I have OpenSSL installed, same as before when I had Unreal running. But this time, during the ./Config, it's tripping out on my OpenSSL. I understand it's telling I have it installed, but I don't understand why Unreal needs more binaries and libraries. On my server, I ran:
apt-get install openssl
But it still won't accept that. And I definitely want SSL for my ircd. Any help wld be greatly appreciated. Thanks.

Landslyde
Posts: 21
Joined: Mon Jun 23, 2014 6:45 pm

Re: Unreal3.2.10.4 not accepting OpenSSL

Post by Landslyde » Sun Jun 14, 2015 2:44 am

Forget it. I guess my mistake was upgrading to debian 8. I guess Unreal needs debian 7 and its associated files to run. Sorry for the post...

katsklaw
Official supporter
Posts: 1114
Joined: Sun Apr 18, 2004 5:06 pm

Re: Unreal3.2.10.4 not accepting OpenSSL

Post by katsklaw » Sun Jun 14, 2015 2:48 am

Unreal compiles fine on Debian 8. If you did a dist-upgrade from debian 7 to Debian 8 you'll have to recompile Unreal. You will need to install the ssl development libraries too: apt-get install libssl-dev

Syzop
UnrealIRCd head coder
Posts: 1879
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Unreal3.2.10.4 not accepting OpenSSL

Post by Syzop » Sun Jun 14, 2015 8:21 am

What katsklaw says is correct. There are a number of openssl packages in Debian (and other Linux distro's), namely:
openssl: this is the 'openssl' command (like, for at the command line)
libssl1.0.0: this is the runtime library
libssl-dev: the development library. needed if you compile anything with OpenSSL (like UnrealIRCd)

You were very likely missing that last one (libssl-dev).

This is true for any library on Linux/Debian by the way, you have a runtime library like libxyz and then a development library that (also) contains header files etc. and is called libxyz-dev (and libxyz-devel on Ubuntu).

Oh and you're absolutely right about wanting SSL. In the future (Unreal3.4.x) you can't even compile UnrealIRCd without it anymore.

Landslyde
Posts: 21
Joined: Mon Jun 23, 2014 6:45 pm

Re: Unreal3.2.10.4 not accepting OpenSSL

Post by Landslyde » Tue Jun 30, 2015 12:52 am

katsklaw & Syzop:

Sorry for the late reply to you both. I wish I'd seen your posts earlier :D I'm still on Deb 7 and Unreal is purring for me. Excellent stuff! I'll upgrade the OS when you guys roll out Unreal3.4.x. Again, thanks for your responses. Much appreciated.

Post Reply