Spam notice

These are old archives. They are kept for historic purposes only.
Post Reply
Hermanus
Posts: 14
Joined: Wed Jan 28, 2015 10:18 pm

Spam notice

Post by Hermanus » Thu Feb 18, 2016 8:48 pm

Hello,

my Unreal version is 3.2.10.4 and Anope-2.0.2

since 2 days some people reported that when they send a YouTube url in a private window that they get this:
[NOTICE irc.place2chat.be]: Message to blauwke blocked: Spam/Advertising
Never had it befoe. Does some one know how this can happen and what I can do against it?

Best regards, Herman.

none
Posts: 7
Joined: Fri Sep 26, 2014 3:40 pm

Re: Spam notice

Post by none » Thu Feb 18, 2016 9:01 pm

Hi, the message or maybe the link contained in the message match a spamfilter pattern.
So when a user see his message blocked, you as oper must recieve a spamfilter match notice that contains the pattern of the spamfilter causing the blocking, you just need to delete the spamfilter entry in question (the one who set it may set a broad/bad regex )

Hermanus
Posts: 14
Joined: Wed Jan 28, 2015 10:18 pm

Re: Spam notice

Post by Hermanus » Thu Feb 18, 2016 9:34 pm

Hello none,

thanks for your reply. Are ir rules like this? Because its reacting on www
regex "^http://www\.angelfire\.com/[a-z0-9]+/[a-z0-9]+/[a-z_]+\.jpg <- .*!";
If thats yes do I need to remove every entry where www is in like that?
And do you mean spamfilter.conf?

Regards, Herman.

Hermanus
Posts: 14
Joined: Wed Jan 28, 2015 10:18 pm

Re: Spam notice

Post by Hermanus » Fri Feb 19, 2016 9:06 am

Hello, I will give some additional information.
I run Unreal for about 6/7 years and never had this problem before. The problem with the spamfilter is started 3 days ago and that is when I linked 2 servers. Last night i put # before the rule include "spamfilter.conf"; located in unrealircd.conf of my own server and the 2 linked servers. Then rehashed them all. But then ther still was this when someone send an url in private:

[Spamfilter] Katten-Meisjee!borgirc@a83-163-54-205.adsl.xs4all.nl matches filter 'www\..+\..+': [PRIVMSG TaTHaR: 'https://www.youtube.com/watch?v=JShXJ3_J-gc'] [Spam/Advertising]

[Spamfilter] Katten-Meisjee!borgirc@a83-163-54-205.adsl.xs4all.nl matches filter 'www\..+\..+': [PRIVMSG TaTHaR: 'www.katten-power.nl'] [Spam/Advertising]

I hope there is some one who can help me.

Best Regards, Herman.

none
Posts: 7
Joined: Fri Sep 26, 2014 3:40 pm

Re: Spam notice

Post by none » Fri Feb 19, 2016 12:14 pm

As i said you just need to delete this spamfilter entry www\..+\..+ following unrealircd syntaxe of /spamfilter command
https://www.unrealircd.org/files/docs/u ... spamfilter
something like this: /spamfilter - type block - - www\..+\..+
replace type with the correspondant type, if you dont know what kind of type type /spamfilter (with no arguments) and look in the list for the type of the regex you post.

Hermanus
Posts: 14
Joined: Wed Jan 28, 2015 10:18 pm

Re: Spam notice

Post by Hermanus » Fri Feb 19, 2016 12:41 pm

Thanx a lot for your reply none. I did /spam and one of the rules coming out was:

F p block 0 70216880 86400 Spam/Advertising WyldDragon!WyldDragon@staff.like2see.you.all www\..+\..+

But where do I find this so I can remove it? Because it is not in spamfilter.conf.

Best regards, Herman.

Hermanus
Posts: 14
Joined: Wed Jan 28, 2015 10:18 pm

Re: Spam notice

Post by Hermanus » Fri Feb 19, 2016 8:18 pm

Hello,

problem solved by deleting the whole list with:

raw 229:*:{ spamfilter - $3-4 $8- }

put in remote and stire and then type /spamfilter in irc and it will delete the spamfilter list.

Thanks for who helped me.

Regards, Herman.

Conty789
Posts: 1
Joined: Sat Aug 20, 2016 9:53 am

Re: Spam notice

Post by Conty789 » Sat Aug 20, 2016 9:56 am

Hermanus wrote:Hello,

my Unreal version is 3.2.10.4 and Anope-2.0.2

since 2 days some people reported that when they send a YouTube url in a private window that they get this:
[NOTICE irc.place2chat.be]: Message to blauwke blocked: Spam/Advertising
Never had it befoe. Does some one know how this can happen and what I can do against it?

Best regards, Herman.
Yes i think the reason is The link or message contained in the message would have been matched to spam filter messages . I mean the same pattern.
Try disabling spam filter and then try

Post Reply