Page 1 of 1

Problem with makew

Posted: Fri Oct 15, 2004 6:39 pm
by Wazp

I have downloaded Unreal3.2 and wanne install it. I have done ./Config and everything was ok, no problems with that, but after that I must do "make". And then come te problems:

CP30061-a:/etc/Unreal3.2 # make
bash: make: command not found

I have found something on the forum about the C Compiler or something, I don't know of that is the problem but i'm using version: gcc version 3.3.1 (SuSE Linux)

As you can see i'm using SuSe version 9.0. I'm trying to install (make) in the shell.

I'm very new with linux and with Unrealircd. So i'm verry sorry when i'm doing something stupid :)

Who have's a solution for this problem?

Greetings, Renzo

Posted: Fri Oct 15, 2004 8:34 pm
by shell
what about gmake?

Posted: Fri Oct 15, 2004 10:10 pm
by Wazp
I had searcht about gmake and i think that you means that i must install that? so i had installed make-3.80.tar.gz that package, there were nog problems installing that but i have the same problem with installing unrealircd...

Posted: Sat Oct 16, 2004 5:12 am
by aquanight
He means to try the command 'gmake' instead of 'make'.

Posted: Sat Oct 16, 2004 8:27 am
by Wazp
That doesn't work.I get the same error :(

Posted: Sat Oct 16, 2004 11:18 am
by shell
Yeh, that is what she meant ;)

Posted: Sat Oct 16, 2004 11:45 am
by Wazp
I don't know why it doesn't works... I have installed that package again and still it doens't work :(

What can i do next?

Posted: Sat Oct 16, 2004 12:09 pm
by Dukat
find / -name make

Posted: Sat Oct 16, 2004 2:47 pm
by Wazp
Dukat wrote:find / -name make
What do you mean with that? must i do that in the shell?

Posted: Sat Oct 16, 2004 3:06 pm
by Dukat
yes... :shock:

Posted: Sat Oct 16, 2004 3:13 pm
by Wazp
I have just installed the RPM Package of Make for Suse and now it works :D

Thx for all the help..

Greetz, Renzo

Posted: Mon Nov 01, 2004 1:17 am
by pomme
There really is no "gmake". When you install GNU Make from the source code, it installs the binary to /usr/local/bin/make by default unless you specify a different prefix. Try doing this to install Unreal:

/usr/local/bin/make all

Edit: installing GNU Make through a package system, for example, the FreeBSD ports collection, yes, you will have gmake, and they use gmake so it won't cause conflicts with your current make program. But as I said, from the source code, the binary file is "make" by default unless you specifically tell it to make the binary "gmake".

Posted: Mon Nov 01, 2004 8:28 am
by Ron2K
For the record: SuSE Personal Edition (what you're probably using) doesn't have make or a C compiler. There are some RPM's around though.