Issues while starting server [4.0.18]

If you hit any installation issues or cannot connect to your freshly installed UnrealIRCd then this forum is for you.

Moderator: Supporters

Post Reply
Quagmire
Posts: 3
Joined: Thu Jul 26, 2018 2:22 pm

Issues while starting server [4.0.18]

Post by Quagmire » Thu Jul 26, 2018 2:25 pm

hey there,

I am using Ubuntu Linux 16.04.5 and would like to start the server. Whenever I am starting it or at least try to, I am getting the following error
/bin/unrealircd: error while loading shared libraries: libssl.so.45: cannot open shared object file: No such file or directory
We tried everything starting from reinstalling openssl ending with using libressl, no change.

Someone an idea?

Quagmire
Posts: 3
Joined: Thu Jul 26, 2018 2:22 pm

Re: Issues while starting server [4.0.18]

Post by Quagmire » Fri Jul 27, 2018 11:24 am

Noone having an idea? Nothing worked so far

Stealth
Head of Support
Posts: 2084
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Re: Issues while starting server [4.0.18]

Post by Stealth » Mon Jul 30, 2018 2:44 am

Does that library exist on your system? If not, you may want to re-build Unreal (if you haven't already). Be sure to run 'make clean' before re-running ./Config

Quagmire
Posts: 3
Joined: Thu Jul 26, 2018 2:22 pm

Re: Issues while starting server [4.0.18]

Post by Quagmire » Tue Jul 31, 2018 9:57 am

Been there, done that - we reinstalles libresll/openssl several times, but no change at all.
Looks like these files still keep missing

Gottem
Posts: 165
Joined: Fri Aug 19, 2016 5:26 pm
Location: NL

Re: Issues while starting server [4.0.18]

Post by Gottem » Tue Jul 31, 2018 1:20 pm

Is the executable unrealircd actually in /bin or did you strip the /home/user part? Cuz you're really not supposed to move any of the files from the installation dir around. You're also not supposed to install as root, keep everything in the homedir and under permissions of a dedicated user. Start over if you touched anything Unreal related as root.

You say you reinstalled libressl/openssl several times, but did you also install the development package? On Ubuntu this should be libssl-dev. If this is missing I think you should've gotten an error during configuration (./Config) to begin with, but I'm not 100% sure on that. Verify you have in fact installed that package, if you haven't then do (from the source directory):

Code: Select all

make clean
rm config.settings
./Config
make
make install
You could also do the following (use the path to the actual executable and not the wrapper script):

Code: Select all

ldd /path/to/bin/unrealircd | grep ssl
# In my case it returns: libssl.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
If you like my modules, pls consider donating (through PayPal) or becoming a monthly Patron ;];]

Post Reply