Help with using a local openssl install

If you hit any installation issues or cannot connect to your freshly installed UnrealIRCd then this forum is for you.

Moderator: Supporters

Post Reply
preacher
Posts: 2
Joined: Mon Feb 01, 2016 4:29 pm

Help with using a local openssl install

Post by preacher » Fri Jul 22, 2016 6:53 pm

I need to use a local install of openssl as the openssl on the server is too old.

I have tried to set the dir in ./Config, and found that there is an open bug track on not being able to set the openssl directory.

following syzop advice I tried modifying the Makefile after ./Config and before make.

adding... IRCDLIBS=-Wl,-rpath=/home/preacher/local/lib -lcrypt

when I try and do make I get....

ssl.c:250:3: error: #error "Your system has an outdated OpenSSL version. Please upgrade OpenSSL."
ssl.c: In function 'init_ctx_server':
ssl.c:252: error: 'SSL_OP_NO_TICKET' undeclared (first use in this function)
ssl.c:252: error: (Each undeclared identifier is reported only once
ssl.c:252: error: for each function it appears in.)
*** Error code 1

Stop in /home/preacher/unrealircd-4.0.4/src.
*** Error code 1

any other workaround I can try and do?

shalom

Preacher

Alahin
Posts: 3
Joined: Sat Jul 23, 2016 9:07 am

Re: Help with using a local openssl install

Post by Alahin » Sat Jul 23, 2016 9:38 am

Hi,

Are you able to upgrade your system's ssl library? if you use Ubuntu, use sudo apt-get update && sudo apt-get upgrade if you use CentOS use sudo yum update.

Regards,
Alahin

preacher
Posts: 2
Joined: Mon Feb 01, 2016 4:29 pm

Re: Help with using a local openssl install

Post by preacher » Thu Jul 28, 2016 3:05 pm

I am using a shell for a backup ircd (freebsd) so unable to update system openssl. So the only way for me to run 4 is with a local install.

Any help anyone?

Shalom

Preacher

Post Reply