help with this error. new to unrealircd

If you hit any installation issues or cannot connect to your freshly installed UnrealIRCd then this forum is for you.

Moderator: Supporters

Post Reply
bootkiller
Posts: 3
Joined: Thu Jul 28, 2016 5:45 pm

help with this error. new to unrealircd

Post by bootkiller » Thu Jul 28, 2016 5:48 pm

checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/root/unrealircd-4.0.5':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details


We will now ask you a number of questions.
You can just press ENTER to accept the defaults!

If you have previously installed UnrealIRCd on this shell then you can specify a
directory here so I can import the build settings and third party modules
to make your life a little easier.
If you install UnrealIRCd for the first time on this shell, then just hit Enter
[] ->

In what directory do you want to install UnrealIRCd?
(Note: UnrealIRCd 4 will need to be installed somewhere.
If this directory does not exist it will be created.)
[/root/unrealircd] ->

What should the default permissions for your configuration files be? (Set this to 0 to disable)
It is strongly recommended that you use 0600 to prevent unwanted reading of the file
[0600] ->

If you know the path to OpenSSL on your system, enter it here. If not
leave this blank (in most cases it will be detected automatically).
[] ->

Do you want to enable remote includes?
This allows stuff like this in your configuration file:
include "http://www.somesite.org/files/opers.conf";
[No] ->

Do you want to enable prefixes for chanadmin and chanowner?
This will give +a the & prefix and ~ for +q (just like +o is @)
Supported by the major clients (mIRC, xchat, epic, eggdrop, Klient,
PJIRC, irssi, CGI:IRC, etc.)
This feature should be enabled/disabled network-wide.
[Yes] ->

How far back do you want to keep the nickname history?
[2000] ->

What is the maximum sendq length you wish to have?
[3000000] ->


How many file descriptors (or sockets) can the IRCd use?
[1024] ->

Would you like to pass any custom parameters to configure?
See `./configure --help' and write them here:
[] ->
./configure --with-showlistmodes --enable-ssl --with-bindir=/root/unrealircd/bin --with-datadir=/root/unrealircd/data --with-pidfile=/root/unrealircd/data/unrealircd.pid --with-confdir=/root/unrealircd/conf --with-modulesdir=/root/unrealircd/modules --with-logdir=/root/unrealircd/logs --with-cachedir=/root/unrealircd/cache --with-docdir=/root/unrealircd/doc --with-tmpdir=/root/unrealircd/tmp --with-scriptdir=/root/unrealircd --with-nick-history=2000 --with-sendq=3000000 --with-permissions=0600 --with-fd-setsize=1024 --enable-dynamic-linking
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/root/unrealircd-4.0.5':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details

TaTHaR
Posts: 37
Joined: Wed Jan 28, 2015 3:28 pm

Re: help with this error. new to unrealircd

Post by TaTHaR » Thu Jul 28, 2016 6:46 pm

I had the same. This on this URL fixed it for me.

http://ask.xmodulo.com/upgrade-gcc-centos.html

Regards, Herman.
Best Regards, Herman.

Post Reply