Page 1 of 1

Build errors

Posted: Tue May 01, 2018 11:21 am
by Viper
hi

I want to upgrade from 3.2 to latest unreal but when trying to install on FreeBSD 10.3, but during ./Config i run into the following error..

Code: Select all

Making install in po
make tre.pot-update
if LC_ALL=C grep 'GNU tre' ../* 2>/dev/null | grep -v 'libtool:' >/dev/null; then  package_gnu='GNU ';  else  package_gnu='';  fi;  if test -n 'tre-general@lists.laurikari.net' || test 'tre-general@lists.laurikari.net' = '@'PACKAGE_BUGREPORT'@'; then  msgid_bugs_address='tre-general@lists.laurikari.net';  else  msgid_bugs_address='tre-general@lists.laurikari.net';  fi;  case `: --version | sed 1q | sed -e 's,^[^0-9]*,,'` in  '' | 0.[0-9] | 0.[0-9].* | 0.1[0-5] | 0.1[0-5].* | 0.16 | 0.16.[0-1]*)  : --default-domain=tre --directory=..  --add-comments=TRANSLATORS: --keyword=_ --keyword=N_   --files-from=./POTFILES.in  --copyright-holder='Ville Laurikari'  --msgid-bugs-address="$msgid_bugs_address"  ;;  *)  : --default-domain=tre --directory=..  --add-comments=TRANSLATORS: --keyword=_ --keyword=N_   --files-from=./POTFILES.in  --copyright-holder='Ville Laurikari'  --package-name="${package_gnu}tre"  --package-version='0.8.0'  --msgid-bugs-address="$msgid_bugs_address"  ;;  esac
test ! -f tre.po || {  if test -f ./tre.pot; then  sed -f remove-potcdate.sed < ./tre.pot > tre.1po &&  sed -f remove-potcdate.sed < tre.po > tre.2po &&  if cmp tre.1po tre.2po >/dev/null 2>&1; then  rm -f tre.1po tre.2po tre.po;  else  rm -f tre.1po tre.2po ./tre.pot &&  mv tre.po ./tre.pot;  fi;  else  mv tre.po ./tre.pot;  fi;  }
test ! -f ./tre.pot ||  test -z "fi.gmo sv.gmo" || make fi.gmo sv.gmo
../utils/install-sh -c -d /home/menace2/unrealircd-4.0.17/extras/regexp/share
install: ./fi.gmo: No such file or directory
*** Error code 71

Stop.
make[1]: stopped in /usr/home/menace2/unrealircd-4.0.17/extras/tre-0.8.0-git/po
*** Error code 1

Stop.
make: stopped in /usr/home/menace2/unrealircd-4.0.17/extras/tre-0.8.0-git
Does anyone have any idea what's causing it or how to fix it..?

Also, on another shell Config offers to download and install curl for me, but the download script which fetches the install package from the unrealircd website runs into a certificate error. If i edit the curlinstall script to suppress the certificate check in wget, it runs fine, but the install script in latest release package doesn't work as is...

Thanks,
Jan

Re: Build errors

Posted: Mon Jun 11, 2018 1:25 pm
by Syzop
If you have the same problem with UnrealIRCd 4.x then feel free to report the issue on https://bugs.unrealircd.org/ and it will be looked at.

For 3.2.x you will receive no support as it is end of life.

Re: If you have the same problem with UnrealIRCd 4.x

Posted: Sun Jul 15, 2018 8:26 pm
by warg
The posted build error is UnrealIRCd 4.x.

Re: Build errors

Posted: Wed Jul 18, 2018 6:20 am
by Syzop
Indeed, you are right. Unfortunately, no bug report was filed.. don't think it will happen now anymore either.