Installing on Ubuntu 18.04 needs libtre.so.5, libpcre2-8.so.0 and libcares.so.2

If you hit any installation issues or cannot connect to your freshly installed UnrealIRCd then this forum is for you.

Moderator: Supporters

Post Reply
timcu
Posts: 1
Joined: Sat Oct 06, 2018 5:17 am

Installing on Ubuntu 18.04 needs libtre.so.5, libpcre2-8.so.0 and libcares.so.2

Post by timcu » Sat Oct 06, 2018 5:33 am

I have a Ubuntu 18.04 server which was previously running unrealircd 4.0.17. I installed unrealircd 4.2.0 from source. When running

Code: Select all

./unrealircd gencloak
I got the following error messages:
error while loading shared libraries: libtre.so.5: cannot open shared object file: No such file or directory
error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory
error while loading shared libraries: libcares.so.2: cannot open shared object file: No such file or directory
For the benefit of other users running Ubuntu I solved the issue by installing the following packages:

Code: Select all

sudo apt install libtre5 libpcre2-8-0 libc-ares2

Syzop
UnrealIRCd head coder
Posts: 1815
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Installing on Ubuntu 18.04 needs libtre.so.5, libpcre2-8.so.0 and libcares.so.2

Post by Syzop » Mon Oct 08, 2018 5:12 pm

That's odd, I use Ubuntu 18.04 on several irc servers, some miss those packages you mention, but they work fine.
Also, nothing changed between 4.0.17 and 4.2.0 with regards to the compile system & these libraries, as far as I remember.

So not sure what happened. The proposed 'fix' should not be necessary.

In any case, if anyone wants to report a bug and wants to help getting things resolved (like this or anything else), there's the bugtracker: https://bugs.unrealircd.org/

Post Reply