Page 1 of 1

Permission Denied

Posted: Tue Nov 20, 2018 12:46 pm
by n3xus100
so i downloaded unrealirc at root folder and unrar it , after i edited example.conf at /doc/conf/examples and renamed unrealircd.conf and copied at /root/unrealircd-4.2.0/doc/conf/ then i run ./Config and set install folder at root/unrealircd (default one), then i run make install and i get this error
make[3]: execvp: ../../buildmod: Permission denied
Makefile:40: recipe for target 'build' failed
make[3]: *** [build] Error 127
make[3]: Leaving directory '/root/unrealircd-4.2.0/src/modules/third'
Makefile:74: recipe for target 'build' failed
make[2]: *** [build] Error 2
make[2]: Leaving directory '/root/unrealircd-4.2.0/src/modules'
Makefile:65: recipe for target 'mods' failed
make[1]: *** [mods] Error 2
make[1]: Leaving directory '/root/unrealircd-4.2.0/src'
Makefile:140: recipe for target 'build' failed
make: *** [build] Error 2
thx for reading, any help is appreciated.

Re: Permission Denied

Posted: Tue Nov 20, 2018 10:28 pm
by The_Myth
I believe, iirc, that UnrealIRCd won't install as root. you need to create a user to install and run UnrealIRCd (check your distro man pages).
Hope this helps
Cheers

Re: Permission Denied

Posted: Wed Nov 21, 2018 3:13 pm
by CrazyCat
NEVER install Unrealircd (or any IRC related) as root !
Create a separate user and use it.