Page 1 of 1

Registration Timeout Error

Posted: Mon Apr 29, 2019 4:46 pm
by Walaryne
Hi there,
I recently setup a Raspberry Pi with Arch Linux in order to run several services from it. Everything else seems to work fine aside from UnrealIRCd. I've attempted to install it from package repos and from source too, to no avail. The IRCd runs, but upon attempting to connect, from ANY location, including localhost and LAN IPs. I constantly get the same error.

Code: Select all

:irc.rynesnet.lan NOTICE * :*** Looking up your hostname...
:irc.rynesnet.lan NOTICE * :*** Couldn't resolve your hostname; using your IP address instead
ERROR :Closing Link: [] (Registration Timeout)
Connection closed by foreign host.
I this is the result of a Telnet connection to the server. All clients I have attempted to use result in the same error.
I am entirely confounded at where the error is. I have even gone as far to flush all IPTables entries. I've even recompiled on my laptop and ensured the config runs without error there.

I sincerely hope someone can help me solve this issue.

Re: Registration Timeout Error

Posted: Mon Apr 29, 2019 4:58 pm
by k4be
It's normal with the telnet client if you had not sent anything. Try the sequence:
USER x x x x
NICK xxxx
Then reply to the PING request (replace PING with PONG).
Don't know why there's the error with usual IRC clients though.

Re: Registration Timeout Error

Posted: Mon Apr 29, 2019 5:21 pm
by Syzop
Do you have a failed session from an actual IRC client with hh:mm:ss timestamps for us? (copy-paste here)

Have you set some kind of weird value for set::handshake-delay perhaps?

Re: Registration Timeout Error

Posted: Mon Apr 29, 2019 6:09 pm
by Walaryne
No, the timeout occurs after 20 to thirty seconds approximately. (It should be whatever the default registration timeout value is.)
I have not changed the handshake delay.
As for raw Telnet commands, I could try, but as far as I know, the server will not respond.
I can get you a timestamp from Hexchat later.
EDIT: I forgot to mention the failed session from the IRC client is the same output from Telnet 1:1.