Mode "o"

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
Warzone
Posts: 4
Joined: Tue Mar 21, 2017 11:33 pm

Mode "o"

Post by Warzone » Tue Mar 21, 2017 11:44 pm

i want to remove the +o from opers i did a lot of googling and i swear most of them showed me exactly what to do but still no result.

From what i understand you can set the

Code: Select all

	modes-on-connect "+ixw"; /* when users connect, they will get these user modes */
	modes-on-oper	 "+kscfvGq"; /* when someone becomes IRCOp they'll get these modes */
	snomask-on-oper "+kscfvGq";
but it wont let me remove the O i'll get stuff like

Code: Select all

(19:30:50)  -› (***.***.***.***) *** error: conf/unrealircd.conf:587: set::modes-on-connect may not include mode 'o' 
i have also tried setting the modes in the oper block and i get

Code: Select all

(19:30:50)  -› (***.***.***.***) *** error: conf/unrealircd.conf:354: oper::modes may not include mode 'o'

i want to stop opers from seeing notices when people Oper-up

Code: Select all

(02:59:32)  -› (services.localhost.net) from OperServ: USERS: Warzone!Warzone@IPHERE is now an IRC operator.
(02:59:57)  -› (services.localhost.net) from OperServ: USERS: God!BotZone@IPHERE is now an IRC operator.

i looked at viewtopic.php?t=3563 which is exatly my problem but the url there isnt working.
same with viewtopic.php?t=5696 = same issue but i followed it and nothing.

I know it''s snomask but like i said i've tried many things with no success

rcschaff
Posts: 44
Joined: Sun Jan 15, 2017 5:06 pm

Re: Mode "o"

Post by rcschaff » Tue Mar 21, 2017 11:52 pm

Mode o is what gives opers oper status. YOu CANNOT remove it. If you don't want them to have o, don't give them a "oline"

Warzone
Posts: 4
Joined: Tue Mar 21, 2017 11:33 pm

Re: Mode "o"

Post by Warzone » Tue Mar 21, 2017 11:55 pm

even if you set the snomask? like i seen lots of people saying they've disabled it.

The snomask "o" = Oper-up notices (/OPER usage)

There is no way to disable just the notices sent?

rcschaff
Posts: 44
Joined: Sun Jan 15, 2017 5:06 pm

Re: Mode "o"

Post by rcschaff » Tue Mar 21, 2017 11:59 pm

Mode o itself is Oper Status. Snomask o is what you want to set, and it should be able to be unset via

snomask-on-oper "+kscfvGq-o" *** Please note, that you have to explicitly enable all modes you want set to on. Setting this to just -o will disable all snomasks.
Last edited by rcschaff on Wed Mar 22, 2017 12:19 am, edited 1 time in total.

Warzone
Posts: 4
Joined: Tue Mar 21, 2017 11:33 pm

Re: Mode "o"

Post by Warzone » Wed Mar 22, 2017 12:16 am

yea i set that and still getting the same issue. i did try that before too adding the -o and only just the -o and still getting them. :( sucks

Code: Select all

(20:14:59)  -› (ip) *** Rehashing all files via the console
(20:14:59)  -› (ip) *** Loading IRCd configuration..
(20:14:59)  -› (ip) *** Configuration loaded without any problems.
(20:15:36)  -› (services.localhost.net) from OperServ: USERS: Mish|!Mish@1IPHERE is now an IRC operator.

Code: Select all

	snomask-on-oper "+kscfvGq-o";

rcschaff
Posts: 44
Joined: Sun Jan 15, 2017 5:06 pm

Re: Mode "o"

Post by rcschaff » Wed Mar 22, 2017 12:21 am

Are you enabling the snomask o in the oper block by chance? Anything set in the individual oper blocks will override anything in the set:: block


Also, you must deop by "/mode <nick> -o" and reoper for any changes to take effect.

Warzone
Posts: 4
Joined: Tue Mar 21, 2017 11:33 pm

Re: Mode "o"

Post by Warzone » Wed Mar 22, 2017 12:31 am

man your a genius the issue was the /mode <nick> -o

that removed the notices but on a reconnect all the settings are back to normal. (not really a concern as i'll just add a /mode $me -o to their connection script.

I did have a snomask setup in the oper block but after reading your comment i removed them.

I really appericate you taking time to help me. Even though its not 100% resolved you made my life so much better.

rcschaff
Posts: 44
Joined: Sun Jan 15, 2017 5:06 pm

Re: Mode "o"

Post by rcschaff » Wed Mar 22, 2017 12:47 am

On reconnect, they should only get the snomasks they are set with in their oper block. //mode -o will make them no longer an oper. SOmething else is going on if the snomask settings aren't getting set. If you would like, I'd be glad to live chat. My server is irc.420-hightimes.com, and I'm in #hightimes-lounge. Might not respond right away, but I'll see a notice.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests