Problem to enable SASL

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
Webmaster78
Posts: 22
Joined: Sun Mar 15, 2020 2:06 am

Problem to enable SASL

Post by Webmaster78 »

I need to enable SASL on my irc.

When I do / quote CAP LS I have the answer ...
CAP LS: unrealircd.org/plaintext-policy=user=allow,oper=warn,server=deny unrealircd.org/link-security=2 extended-join chghost cap-notify userhost-in-names multi-prefix away-notify account -notify tls message-tags

I have respected, unless I'm mistaken, the indications of https://www.unrealircd.org/docs/SASL
In anope I edit the file modules.conf : module { name = "m_sasl" }.
In unreal I edit the file unrealircd.conf : set { sasl-server services.my.net; }; with my own.

Anope is well connected and active.

I have rehash.

What can be my problem ?
Syzop
UnrealIRCd head coder
Posts: 1974
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Problem to enable SASL

Post by Syzop »

Although it may not be directly related to your problem, we noticed you are using an outdated UnrealIRCd version. So upgrade to UnrealIRCd 5 and also make sure you are using a recent anope version (2.0.7 or later).

SASL should then work out of the box once services are linked in. (And they are linked right? You can /WHOIS ChanServ ?)

If it doesn't work:
  • In UnrealIRCd both set::services-server or set::sasl-server should point to your services server.
  • In anope be sure to use the protocol module 'unreal4' (which is for unrealircd 4.x and higher) and not 'unreal' (which is for 3.2.x).
  • Obviously don't unload the sasl module in unrealircd or anope. By default the sasl module is loaded on both correctly though!
Webmaster78
Posts: 22
Joined: Sun Mar 15, 2020 2:06 am

Re: Problem to enable SASL

Post by Webmaster78 »

.
.

It's not working at the moment.

Now I updated Unrealircd I have unrealircd-5.0.9.1 and anope-2.0.7 configuration. But in the end I have the following message in the server window from the applet:
SASL request timed out (server or client misbehaving) - aborting SASL and continuing connection …

When I do /quote CAP LS I’ve got :
[00:13:44] CAP LS :unrealircd.org/link-security=2 unrealircd.org/plaintext-policy=user=allow,oper=deny,server=deny extended-join chghost cap-notify userhost-in-names multi-prefix away-notify sasl tls account-notify message-tags batch account-tag server-time echo-message labeled-response
[00:13:44] CAP ACK :extended-join cap-notify userhost-in-names multi-prefix away-notify sasl account-notify message-tags batch account-tag server-time


For some people for whom it works on their server, with the command / quote CAP LS they have in the answer "sasl = EXTERNAL, PLAIN" which I don't have. Perhaps this is the concern ?

I have the following more detailed information :
[00:48:49] [C] CAP LS 302
[00:48:49] [C] NICK Toto
[00:48:49] [C] USER Toto 0 * https://kiwiirc.com/
[00:48:49] [S] control connected
[00:48:51] [S] :irc.tchat.org CAP * LS :unrealircd.org/link-security=2 unrealircd.org/plaintext-policy=user=allow,oper=deny,server=deny extended-join chghost cap-notify userhost-in-names multi-prefix away-notify sasl tls account-notify message-tags batch account-tag server-time echo-message labeled-response
[00:48:51] [C] CAP REQ :extended-join cap-notify userhost-in-names multi-prefix away-notify sasl account-notify message-tags batch account-tag server-time
[00:48:51] [S] PING :DC0FD584
[00:48:51] [C] PONG DC0FD584
[00:48:51] [S] :irc.tchat.org CAP Nemo ACK :extended-join cap-notify userhost-in-names multi-prefix away-notify sasl account-notify message-tags batch account-tag server-time
[00:48:51] [C] AUTHENTICATE PLAIN
[00:49:08] [S] :irc.tchat.org NOTICE Toto :SASL request timed out (server or client misbehaving) -- aborting SASL and continuing connection...
[00:49:08] [S] :irc.tchat.org 906 Toto :SASL authentication aborted
[00:49:08] [C] CAP END


What to do ?
Thank you !
.
.
Webmaster78
Posts: 22
Joined: Sun Mar 15, 2020 2:06 am

Re: Problem to enable SASL

Post by Webmaster78 »

.
.
The problem is solved. The reason for this was incorrect settings for Anope and Unreal. There were two registered servers with the same name by mistake and basically SASL didn't know which way to go.
.
.
Post Reply