Disable selected SSL/TLS versions

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Locked
Alucard
Posts: 9
Joined: Fri Mar 06, 2009 3:12 am

Disable selected SSL/TLS versions

Post by Alucard » Mon Dec 28, 2015 7:08 pm

For Unreal 4, I see sslv3 was removed entirely, which is good.
Is there a way to control the allowed protocols (not just ciphers) (in either 3.2.x or 4.x)? For example if TLS 1.0 is broken tomorrow.

MOD EDIT: this post was moved to a new thread

Syzop
UnrealIRCd head coder
Posts: 1957
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: POODLE vulnerability

Post by Syzop » Tue Dec 29, 2015 6:13 pm

I believe someone mentioned this before but it was never submitted to bugs.unrealircd.org so I/we forgot about it.

I've added the feature request now as #4523.

Locked