new Web IRC Block

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Locked
DruidTroy
Posts: 1
Joined: Tue Feb 23, 2016 11:39 am

new Web IRC Block

Post by DruidTroy » Tue Feb 23, 2016 11:52 am

please forgive me if this question has been asked in a previous thread, I looked around and could not find a solution to my issue.

First off, I never had to specify a block in an older release so the requirement was new to me.

I have the following blocks in my unrealircd.conf

webirc {
mask 64.62.228.82;
password passset;
};

I have this repeated for each of the current listed data centers mibbit uses.

in my cgiirc.conf I have the syntax as follows ( this is where I was not clear on syntax as I used the suggested format in the manual )

webirc_password {
passset;
};

i also just used webirc_password = passset <-- that did not work either.

when I try to connect to the server via mibbit it tells me incorrect password.

Thanks in advance.

dboyz
Posts: 68
Joined: Tue Jun 14, 2011 6:36 am

Re: new Web IRC Block

Post by dboyz » Wed Feb 24, 2016 6:16 am

Hello,

1) I assume you are using unrealircd-4.0.0 or higher.
2) The webirc block in unrealircd.conf is correct.
But
3) I don't think cgiirc.conf exists in unrealircd nor mibbit.

Note that webirc only works if mibbit connects to the specific server with webirc enabled and configured.
Also, do remember to rehash after configuring webirc.

Locked