how to start using privdeaf

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
TaTHaR
Posts: 37
Joined: Wed Jan 28, 2015 3:28 pm

how to start using privdeaf

Post by TaTHaR » Sun Jan 15, 2017 9:34 pm

I use Unrealircd 4.0.10

Hello,

I would like to use the module privdeaf but I can not get it working. Can some one help me with this?

Best regards, Herman.
Best Regards, Herman.

rcschaff
Posts: 53
Joined: Sun Jan 15, 2017 5:06 pm

Re: how to start using privdeaf

Post by rcschaff » Mon Jan 16, 2017 1:34 am

//mode $me +D (If Mirc)
/mode (nick) +D (other)

privdeaf is enabled by default.

TaTHaR
Posts: 37
Joined: Wed Jan 28, 2015 3:28 pm

Re: how to start using privdeaf

Post by TaTHaR » Mon Jan 16, 2017 2:04 am

Hello rcschaff,

thank yuo for your reply.

On Mirc the first command //mode $me +D (If Mirc) is working fine.
I also run a flash webchat specially for Mirc but command 1 is not working, It gives- Unknown command "/mode"

The second command /mode nick +D don't work on Mirc. I get this: Cant change mode for other users
on light IRC webchat it also gives: Cant change mode for other users

Best Regards, Herman.
Best Regards, Herman.

rcschaff
Posts: 53
Joined: Sun Jan 15, 2017 5:06 pm

Re: how to start using privdeaf

Post by rcschaff » Mon Jan 16, 2017 4:32 am

That's Because privdeaf is a per user option. the "/mode" command only works on your user. /mode (someone else) will result in nothing. It has to be "/mode mynick +modes"

If you want to disable Private Messages for Everyone upon connection, see set::modes-on-connect

That of course doesn't mean they can't turn it off. so you should add it to set::restrict-usermodes to keep it locked on.

As for setting another users mode. This has to be done via a U Lined server (Services). Anope has "/os umode <nick> +D" as an example.

Documentation.
https://www.unrealircd.org/docs/Set_blo ... -usermodes

TaTHaR
Posts: 37
Joined: Wed Jan 28, 2015 3:28 pm

Re: how to start using privdeaf

Post by TaTHaR » Mon Jan 16, 2017 2:11 pm

Hello,

for as far I tested, the only thing that works is //mode $me +D on me myself. 2 others tryed the same and for then i did not worked.

Also in LightIRC webvhat it does noet work. Am I doing something wrong? Is there a way to set settings?

Best reagrds, Herman.
Best Regards, Herman.

rcschaff
Posts: 53
Joined: Sun Jan 15, 2017 5:06 pm

Re: how to start using privdeaf

Post by rcschaff » Tue Jan 17, 2017 1:46 am

I'm not sure why It would not work on any client. /mode <mynick> +D should work because it's a server thing. Are they getting any type of message when it fails, such as "/mode command not found".

It very well could be their client has a /mode option and doesn't forward it to Unreal, but that's a long shot.

Post Reply