Cannot connect to SSL port

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
ratafonso
Posts: 1
Joined: Mon Nov 06, 2017 5:00 pm

Cannot connect to SSL port

Post by ratafonso » Mon Nov 06, 2017 5:24 pm

Hello Guys,

I'm trying to up my UnrealIRCd server with SSL, but, i've finded some issues with configuration:

I'm using mIRC 7.51 Trial Edition.

When i'm connecting in 6697 SSL port, mIRC told me: "[10053] Software cause connection abort".

Following my listen configuration below. I'm using the OpenSSL certificates generated in unrealircd installation.

Code: Select all

/* Standard IRC port 6667 */
listen {
        ip *;
        port 6667;
};

/* Standard IRC SSL/TLS port 6697 */
listen {
        ip *;
        port 6697;
        options { ssl; };
        ssl-options {
                certificate "/irc/unrealircd/conf/ssl/server.cert.pem";
                key "/irc/unrealircd/conf/ssl/server.key.pem";
                options { no-client-certificate; };
                };
};
/* Special SSL/TLS servers-only port for linking */
listen {
        ip *;
        port 6900;
        options { ssl; serversonly; };
};
Someone can help me?

MOD EDIT: I've split off your question to a new thread

Syzop
UnrealIRCd head coder
Posts: 1800
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Cannot connect to SSL port

Post by Syzop » Sun Nov 12, 2017 8:21 am

Did you tell mIRC that you are connecting to an SSL port? You have to do so explicitly:

Code: Select all

/server server-name-or-ip +6697
Note the + sign before the port.

Post Reply