Page 1 of 1

SVSNOLAG

Posted: Tue Feb 13, 2018 1:38 pm
by Moya
hi, (sorry for my english, i'm french :) )

I've problem with SVSNOLAG in m_svsnolag.c, i want enable 'svsnolag + nick' command for opers, but I do not know how to do it.
i've read is possible, i've try 'nofakelag' in opers block in unreal conf but it not work.

thx.

Re: SVSNOLAG

Posted: Tue Feb 13, 2018 2:24 pm
by Moya
[edit]
In fact, my problem is to succeed in removing the "fake lag" from the server for somebody

Re: SVSNOLAG

Posted: Thu Feb 15, 2018 4:25 pm
by Gottem
Well first of all, this particular board is for third party modules, not built-in features. You'll want to post stuff like this in Generic support instead.

Second: notice how the command begins with SVS? That means it's reserved for U:Lined servers (services) only and no oper can use it directly.

Third, the wiki page has a few pretty clear paragraphs about fake lag. Opers are already exempt, are you sure you need to disable it? If so: you don't put nofakelag in an oper block but a class one.

Re: SVSNOLAG

Posted: Fri Feb 16, 2018 8:43 am
by Moya
hi

Code: Select all

class opers
{
        pingfreq 90;
        maxclients 50;
        sendq 100M;
        recvq 32k;
        nofakelag;
};
And i've this message :

Code: Select all

/unrealircd.conf:36: class::nofakelag specified without a value
*** error: 1 errors encountered

Re: SVSNOLAG

Posted: Sun Feb 18, 2018 4:57 pm
by Gottem
Maybe you should read what I said before (stubbornly) going on about disabling it. Seeing as how your class block is called "opers", you do not need to disable fake lag:
Gottem wrote:
Thu Feb 15, 2018 4:25 pm
Opers are already exempt, are you sure you need to disable it?