Page 1 of 1

nofakelag

Posted: Sat May 26, 2018 3:39 am
by DeltaZed
Hello,

I've recently installed and am running unrealircd v4.0.17. It's a private server and we share a lot of code snippets on it so we're looking to disable the imposed fake lag. I've recompiled by changing this line in config.h:

#define FAKELAG_CONFIGURABLE

and adding this to my class block for clients:

class clients
{
pingfreq 90;
maxclients 20;
sendq 1M;
recvq 32k;
options {
nofakelag;
};
};

Restarted the server, it takes the config with no complaints, but everyone is still rate-limited. After several lines the ~2-second delay kicks in. Even the /oper (me) experiences this problem. The client I'm testing with is irssi and hexchat.

I understand that turning off fake lag is undesirable in the wild but this is a private server so it's not an issue (and if it is we can pummel the person causing the problem in person).

Help? I'm a noob at being an IRC operator and I have only used IRC minimally over the years, but not enough to really have a deep understanding of the protocol or the different implementations of it.

Please let me know if there's any information I can provide. Your assistance is greatly appreciated!

-DeltaZed

Re: nofakelag

Posted: Sat May 26, 2018 5:00 am
by Stealth
You may also wish to check your client settings, as many clients have built-in rate limiting that gets in the way as well.

Re: nofakelag

Posted: Sat May 26, 2018 7:21 pm
by DeltaZed
I definitely looked into irssi settings as well (which is why I tried the hexchat client, too) but couldn't find anything; well over two hours of googling and RTFMing.

Another odd tidbit: I'm using a third-party service to tie Slack into our IRC server, and the bot doesn't have the rate-limiting problem. That supports your suggestion that it could be the client. Like I said, I use IRC lightly but am not intimately familiar with it so I'm not aware of the more esoteric aspects of usage/config/etc.

I suppose I'll wander over to an irssi form and see what people there have to say.

Re: nofakelag

Posted: Sat May 26, 2018 8:04 pm
by Gottem
Also, unless you have funky operclasses then opers are already exempt from fakelag since all the default operclasses have the top-level privilege privacy. Is anyone connecting through ZNC perhaps? Because they also include "flood protection" to prevent you from getting killed for Excess Flood, amongst other things.
DeltaZed wrote:
Sat May 26, 2018 3:39 am
After several lines the ~2-second delay kicks in. Even the /oper (me) experiences this problem. The client I'm testing with is irssi and hexchat.
A quick Google for "irssi flood protection" gave me something that may be of interest. It seems it defaults to 5 commands (or "lines", since each line is actually one PRIVMSG command) per 2.2 seconds, so if your pals are getting that amount of lines at once that might the cause.

Re: nofakelag

Posted: Sat May 26, 2018 8:19 pm
by DeltaZed
I got that operators should be exempt from rate limits which is why I posted it as another data point.

I read through the irssi page you sent and couldn't find much of interest. In particular I did try to set cmds_max_at_once to 20, and even cmds_max_at_once to 10ms. Problem persists.

I've already downloaded the irssi source and am starting to poke around and see if I can find anything.

Thanks for the suggstions, though!

Re: nofakelag

Posted: Sun May 27, 2018 11:00 am
by Gottem
Yeah I figured that, just thought I'd clarify a bit. =] I don't use irssi myself so unfortunately I'm out of ideas, but you could also join their support IRC instead of poking around the source. Will probably get a proper answer much faster that way.

Re: nofakelag

Posted: Wed Jan 23, 2019 4:42 am
by acidvegas
See if https://supernets.org/docs/ascii-ansi-art-flooding.html helps for setting up your client to flood without throttle.