U5.0.5.1: Message limit for defined nofakelag? (SOLVED)

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Locked
Runelish
Posts: 2
Joined: Sun Jun 14, 2020 1:17 pm

U5.0.5.1: Message limit for defined nofakelag? (SOLVED)

Post by Runelish » Sun Jun 14, 2020 1:58 pm

Hello all,

recently migrated from Unreal 3.2 to Unreal 5.0.5.1 if we can call it that. Set it up from scratch with the old conf as a reference.
So as also the old Unreal 3.2 was configured with nofakelag defined, I did it also for new Unreal 5.0.5.1.
In conf there are certain parts for that to make it work:

Code: Select all

class           the-user-group-that-can-flood
{
        pingfreq 90;
        maxclients 50;
        sendq 3000000;
        recvq 32000;
        options
        {
                nofakelag;
        };
};
---
allow {
        ip              *@*;
        hostname        *@*;
        class   the-user-group-that-can-flood;
        password        "the-secret-password";
        options
        {
                nopasscont;
        };
};
So with new Unreal 5.0.5.1 logging on as that user class works as it did with old Unreal.

However I experience something I could not determine any further:
Private messages are limited to 30 lines at once and if there are more lines, they are displayed to the sender as they were sent but for the receiver those are lost and never show.

This behaviour does not occur when a user is identifying to the server for IrcOp permissions (/oper).

Also tried to find a reference in docs, faq or my conf file how to remove this limitation but I could not find anything and I'm out of ideas.
Or do I need to define anti-flood -> target-flood settings as not having them in the conf means they are active with defaults as seen in config doc?
I hope someone can help here. Thanks up front!
Last edited by Runelish on Sun Jun 14, 2020 2:36 pm, edited 1 time in total.

Runelish
Posts: 2
Joined: Sun Jun 14, 2020 1:17 pm

Re: U5.0.5.1: Message limit for defined nofakelag?

Post by Runelish » Sun Jun 14, 2020 2:36 pm

Perfect example of being a internet forum noob -.-
It is perfectly working now after adding "blacklist-module targetfloodprot;" to the unrealircd.conf. In this case the correct one in conf/ and not in the main Unreal folder.

Sorry everyone and still thanks because posting here made me look closer.

Syzop
UnrealIRCd head coder
Posts: 1955
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: U5.0.5.1: Message limit for defined nofakelag? (SOLVED)

Post by Syzop » Tue Jun 16, 2020 6:40 am

Thanks for the feedback. I have added the question to the FAQ and we refer to it from the nofakelag FAQ question as well.

I can totally understand how you missed it if you didn't read the 5.0.5 changelog, something which is far more likely to happen with future releases as most people are not going to read back changelogs from X versions ago.

Locked