Hidden-host

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
Peter
Posts: 4
Joined: Wed Oct 14, 2020 10:08 am

Hidden-host

Post by Peter » Wed Oct 14, 2020 10:12 am

I have installed unrealircd 5 on windows 10 machine, after anope was up n running, its now showing at all hidden-host !!!

Any tip for this issue ?

Win 10, dual core, 8 gb of ram on that win box.

I have debian 10 on other machine and there is working good with hidden-host

Syzop
UnrealIRCd head coder
Posts: 1955
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Hidden-host

Post by Syzop » Wed Oct 14, 2020 10:40 am

It's not entirely clear to me. Can you give us an example what you see, what you want and what you don't want?

Peter
Posts: 4
Joined: Wed Oct 14, 2020 10:08 am

Re: Hidden-host

Post by Peter » Wed Oct 14, 2020 7:04 pm

On my debian server with debian 10 on its show the right way @lvs-A3D053DA.tbcn.telia.com

hidden-host there is "lvs"

and on my win 10 box its shows up like this :
when some one join to the channels :

@c-11c4e455.029-204-6d6c6d4.bbcust.telenor.se

hidden-host there is "las"

Lord255
Posts: 46
Joined: Sat Feb 29, 2020 12:58 am
Location: offline

Re: Hidden-host

Post by Lord255 » Wed Oct 14, 2020 7:58 pm

could you please give us some more info like:
1, how many servers do you have in your network? only one?
2, what is your setting for hiddenhost-prefix?
see: https://github.com/unrealircd/unrealirc ... .conf#L433
3, if you have multiple servers, are the cloak keys the same? did you set those right?
see: https://github.com/unrealircd/unrealirc ... #L436-L447

are all the clients using usermode +x?
cloaked hosts only activates if the user sets +x usermode.
/mode nick +x

+x can be set on connect like this:
https://github.com/unrealircd/unrealirc ... .conf#L454

so what are your settings?

Peter
Posts: 4
Joined: Wed Oct 14, 2020 10:08 am

Re: Hidden-host

Post by Peter » Wed Oct 14, 2020 8:26 pm

I have 2 ircd, on different network, not linked to each other, one at a win 10 machine, I will try this :
modes-on-connect "+ixw"; and see how its working

hidden-host "las" on win 10 machine
hidden-host "lvs" on debian 10 machine.

Lord255
Posts: 46
Joined: Sat Feb 29, 2020 12:58 am
Location: offline

Re: Hidden-host

Post by Lord255 » Wed Oct 14, 2020 10:00 pm

so.. whenever someone connects to your servers, they should set usermode +x to activate the cloaked host.
which should be las-* on win10 and lvs-* on debian.

the cloak keys should be set and i said, the users should set +x on themselves, or you force them with "modes-on-connect" :)

all good? let us know if you still encounter any problems

Peter
Posts: 4
Joined: Wed Oct 14, 2020 10:08 am

Re: Hidden-host

Post by Peter » Thu Oct 15, 2020 4:02 am

Yeah, now its working with hidden-host at the win10 machine.
When the connect they got :

@las- in the line of the host ;)

Thank you for your excellent help here !!!

Lord255
Posts: 46
Joined: Sat Feb 29, 2020 12:58 am
Location: offline

Re: Hidden-host

Post by Lord255 » Thu Oct 15, 2020 5:12 am

good. you are welcome.
have a nice one! :)

Post Reply